Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

2 Posts

06-06-2014

United States

5 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎06-06-2014
  • Location: United States
  • Views: 30
  • Message 1 of 2

Thinkpad E14 flickers at boot after BIOS and intel chipset driver updates

2020-07-29, 11:08 AM

Hi,

 

   I bought thinkpad E14 this week. I bought it without OS, as I wanted to build a dual boot with windows 10 and Linux.

 

After installing windows 10 from bootable USB, I applied display, intel chipset and BIOS updates. After this I noticed that at the time of booting screen flickers 4-5 times (~15 sec) before OS boot loader appears.

 

  I see same behavior at the time of entering into BIOS. Screen flickers before it goes into BIOS.

 

Yesterday I have also installed ubuntu on it.

 

Flickering stops ones it reaches BIOS or OS boot loader (GRUB).

 

Is anyone facing similar issue on E14 laptops ?

 

Regards,

-Manish

Reply
Answer
Options

2 Posts

06-06-2014

United States

5 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎06-06-2014
  • Location: United States
  • Views: 30

Re:Thinkpad E14 flickers at boot after BIOS and intel chipset driver updates

2020-08-05, 2:43 AM

Figured it out. 
 

When you install OS in legacy or both “legacy and uefi” mode of bios then upon booting screen flickers 4-5 times for 15-20 second.

 

I just tried loading default bios settings, which enable uefi only mode, installed windows 10 and Ubuntu. This resolved the problem.

 

But legacy bios mode issue is a bug and I have asked Lenovo support to fix it.

Reply

Replies(1)
Answer
Options

2 Posts

06-06-2014

United States

5 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎06-06-2014
  • Location: United States
  • Views: 30
  • Message 2 of 2

Re:Thinkpad E14 flickers at boot after BIOS and intel chipset driver updates

2020-08-05, 2:43 AM

Figured it out. 
 

When you install OS in legacy or both “legacy and uefi” mode of bios then upon booting screen flickers 4-5 times for 15-20 second.

 

I just tried loading default bios settings, which enable uefi only mode, installed windows 10 and Ubuntu. This resolved the problem.

 

But legacy bios mode issue is a bug and I have asked Lenovo support to fix it.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms