cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mahima_hada
Ctrl-Alt-Del
Posts: 8
Registered: ‎12-02-2010
Location: New York
Views: 7,034
Message 1 of 9

Display flickers (goes blank) based on power/battery

Hi,

 

I just received my new Thinkpad Edge 14. Whenever I plug in the laptop to the power cord or plug it out, my screen goes blank for a second, and then comes back up. Very weird. 

 

I've tried making the brightness level the same in both settings (power and battery) and I turned off the graphic display management option for "battery" in graphics properties.

 

I would like to see if this can be rectified soon (within my returnable period), or is this is a harbinger of display problems down the road (so, I should return it?)

 

thanks!

mahima_hada
Ctrl-Alt-Del
Posts: 8
Registered: ‎12-02-2010
Location: New York
Views: 7,007
Message 2 of 9

Re: Display flickers (goes blank) based on power/battery

Forgot to add. I have the i5, 4GB RAM, 64 bit, Intel HD Graphics BR 1004 01Y1, Monitor Thinkpad display 1366X768
jimtristate
Fanfold Paper
Posts: 11
Registered: ‎12-02-2010
Location: ohio valley
Views: 7,004
Message 3 of 9

Re: Display flickers (goes blank) based on power/battery

Your description sounds similar to another thread talking about LCDs blanking randomly.  I'm convinced this problem is caused by a faulty LCD lid switch and seems to be quite common in the Edge. The switch is a magnetic sensor and very sensitive.

mahima_hada
Ctrl-Alt-Del
Posts: 8
Registered: ‎12-02-2010
Location: New York
Views: 6,994
Message 4 of 9

Re: Display flickers (goes blank) based on power/battery

Thanks! I did go through that thread. In my case it is not random at all. I remove the power cord - blank and back. I put in the power cord - blank and back. Repeatable patten, very annoying. 

jimtristate
Fanfold Paper
Posts: 11
Registered: ‎12-02-2010
Location: ohio valley
Views: 6,992
Message 5 of 9

Re: Display flickers (goes blank) based on power/battery

Likewise, I'm on the verge of returning it.  Hate to, cause I like it.

paulbhushan
What's DOS?
Posts: 3
Registered: ‎03-11-2011
Location: 75428
Views: 6,577
Message 6 of 9

Screen goes blank when trying to connect Ac adaptor

Hello,

I got my new Lenovo Thinkpad Edge 14" laptop. The probem is when ever i'm trying to coneect or disconnect the AC adaptor the screen goes blank for 2 seconds and comes back to normal again. 

Is this normal with every other Thinkpad Edge?

If not Please suggest me solution to solve this issue.....!

 

Thanks in advance...

Paul

Community SuperMod
Community SuperMod
Posts: 4,569
Registered: ‎04-25-2008
Location: US
Views: 6,537
Message 7 of 9

Re: Screen goes blank when trying to connect Ac adaptor

Hi paulbhushan, and welcome to the Lenovo User Community!

 

Try binaryspiral's solution:

 

http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T400-screen-blinks-when-AC-power-is-connect...

 

Hope this helps!

I don't work for Lenovo. I'm a crazy volunteer!
paulbhushan
What's DOS?
Posts: 3
Registered: ‎03-11-2011
Location: 75428
Views: 6,507
Message 8 of 9

Re: Screen goes blank when trying to connect Ac adaptor

Thanks a lot bananaman.... u saved the day.

now the blinking is gone.

But is there any other solution that we can keep the screen refresh rate 60 Hz and do this...?

 

Anyways thanks a lot bro..

Community SuperMod
Community SuperMod
Posts: 4,569
Registered: ‎04-25-2008
Location: US
Views: 6,496
Message 9 of 9

Re: Screen goes blank when trying to connect Ac adaptor

Hi paulbhushan, Glad that worked!

 

As far as I know that's just how the graphics works, and there is no way to stop the temporary blackout when changing refresh rates.

 

What is it that works for you at 60Hz but not at 50Hz? I have to admit that for everything I do 50Hz or 60Hz makes no difference.

I don't work for Lenovo. I'm a crazy volunteer!

Check out current deals!


Shop current deals

Top Kudoed Authors