cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
johnmoore37
Paper Tape
Posts: 5
Registered: ‎08-31-2015
Location: United States
Views: 881
Message 1 of 9

E420 Ethernet not functioning

I've recently discovered that my ethernet port does not seem to be functioning. I spend most of my time on wifi, so I'm not sure exactly when this began, but I do know that I have used my ethernet port in the past without problems. I've attempted to update the Realtek Ethernet Controller  driver, but I received a message stating, "The Realtek Network Controller was not found. If in Deep Sleep Mode is enabled Please Plug the Cable." 

I'm unware of any "deep sleep" mode, but the LAN adaptor does not appear in my Device Manager list. I know it has worked in the past because I have some LAN connection profiles saved in Lenovo Access Connection app but when I view those profiles it now says under the adaptor name "Realtek PCIe GBE Family Controller - Device Not Found"

I ran a hardware scan using the Solution Center, and the PCI Express section shows the device as connected. 

 

Is my port shot or is this a software issue that can be corrected without gutting my laptop to replace power jack/LAN board? 

Retired Support Specialist
Posts: 473
Registered: ‎07-14-2015
Location: Bangalore
Views: 864
Message 2 of 9

Re: E420 Ethernet not functioning

Hi johnmoore37,

 

Welcome to Lenovo Forums!

 

Try reinstalling the OS and please confirm me is there any damage in the LAN port.

 

Please let us know, whether the above step helped you.

Thank you, have a good day.

 

Regards,

Naveen.v

johnmoore37
Paper Tape
Posts: 5
Registered: ‎08-31-2015
Location: United States
Views: 858
Message 3 of 9

Re: E420 Ethernet not functioning

There is no visible damage to the LAN port. Can you suggest any resorces for reinstalling my OS (win7 pro 64-bit). I don't have a disc. 

johnmoore37
Paper Tape
Posts: 5
Registered: ‎08-31-2015
Location: United States
Views: 856
Message 4 of 9

Re: E420 Ethernet not functioning

Would upgrading to windows 10 achieve the same goal? 

Retired Support Specialist
Posts: 473
Registered: ‎07-14-2015
Location: Bangalore
Views: 839
Message 5 of 9

Re: E420 Ethernet not functioning

Hi johnmoore37,

 

Before I assist you for reinstallation of windows 7, I would request you try checking in the device manager in the hidden devices. To check the same please go through the steps given below.

Click on the windows menu > in search bar type device manager and click enter > in device manager you see an option called view at the left top, click on that > once you click on that you will get several options with “show hidden devices” > click on hidden devices and check the whether the driver is seen. If it detects, then please try to uninstall and reinstall the drivers.

 

For your information, you won’t be able to upgrade it to windows 10 for E420. As per our Lenovo support site the machine is not supported for windows 10 installation, even if you try there would be some issues while upgrading it. For your reference, please find the link given below for a better clarification.

https://support.lenovo.com/sk/sk/documents/ht103535#thinkpad

 

Please let me know, whether the above steps helped you.

Thank you, have a good day.

 

Regards,

Naveen.v

johnmoore37
Paper Tape
Posts: 5
Registered: ‎08-31-2015
Location: United States
Views: 828
Message 6 of 9

Re: E420 Ethernet not functioning

I did not find any hidden realtek devices. I did have a number of hidden WAN Miniport devices (IP, IPv6, L2TP, Network Monitor, PPOE, PPTP) that when I tried to update their drivers, I received a message stating that "The system cannot find the file specified." Should I uninstall those devices or am I looking for something else?  

Retired Support Specialist
Posts: 473
Registered: ‎07-14-2015
Location: Bangalore
Views: 810
Message 7 of 9

Re: E420 Ethernet not functioning

Hi johnmoore37,

 

Can you please check in safe mode with networking, disconnect the router from internet and see if you can connect to the router again.

 

Please let me know, whether the above ep helped you.

Thank you, have a good day.

 

Regards,

Naveen.v

johnmoore37
Paper Tape
Posts: 5
Registered: ‎08-31-2015
Location: United States
Views: 803
Message 8 of 9

Re: E420 Ethernet not functioning

I booted in safe mode but was unable to connect to the router. 

Retired Support Specialist
Posts: 473
Registered: ‎07-14-2015
Location: Bangalore
Views: 787
Message 9 of 9

Re: E420 Ethernet not functioning

Hi johnmoore37,

 

 

Guess it seems to be a hardware issue i.e. Ethernet port issue, hence kindly request you to take the laptop to the nearest authorised service centre for the further assistance. Please find the link given below to find the authorised service centre according to your location.

 

Click here to open a link where you can select the country and get the exact contact support number. I’m sure they will be a great help.

OR

http://bplocator.lenovo.com/

 

Please let me know, whether the above suggestion helped you.

Thank you, have a good day.

 

Regards,

Naveen.v

Check out current deals!


Shop current deals

Top Kudoed Authors