cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
geogre
Fanfold Paper
Posts: 23
Registered: ‎06-23-2011
Location: lithium
Views: 2,807
Message 1 of 75

E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

hello,

 

after the bios and driver update from the long thread about the problems with the switchable graphics, the computer is more silent than before.

 

before, i noticed the fan going on every now and the for just a short time, and at first i was happy that it was not making this a little bit disturbing noise and i thought it was just more constant but slower.

 

but sometimes it just seems to stay off completey, causing the laptop to get really warm under the left hand (somewhere around the A key). when this happens and i reboot the computer, it notices instantly that something's wrong and the fan runs fully and cools down the laptop in like one minute.

 

does someone else have this strange and maybe dangerous behaviour and is there a way to make any settings in bios or drivers to let the temperature stay low?

 

thanks for any help!

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 2,766
Message 2 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

That does sound dangerous indeed.

I'd try reflashing the BIOS just in case something didn't go right.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Former Employee
Posts: 3,823
Registered: ‎07-11-2010
Location: Malaysia
Views: 2,713
Message 3 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

@geogre,

Try to update the BIOS again as suggested by Colonel. Also in another note, are you experiencing any brightness adjustment issue via F7 and F8 keys?

http://forum.lenovo.com/t5/ThinkPad-Edge/E420s-E420-E520-Unable-to-change-brightness-after-upgrading...

//JameZ
Benik3
Punch Card
Posts: 53
Registered: ‎10-22-2011
Location: Czech Republic
Views: 2,696
Message 4 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

Same problem here.

I tried update bios again with boot CD, but it said, that there is not needed to update bios...

vinci
Paper Tape
Posts: 11
Registered: ‎11-23-2011
Location: Beirut
Views: 2,669
Message 5 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

Hello, I have a different problem (the 'opposite') after having installed the latest BIOS driver. Actually, I am not sure if it's related exclusively to the bios driver or to switching manually between the video cards. Anyway, the problem is that the fan is constantly running, even though the cpu runs at very low levels (0-2%, somtimes max. 12%). So there's in inconsistence. Any help?

 

Thanks.

 

Also, can you explain to me how to reinstall the bios driver? I did it through lenovo update software, so it's obvious that it is not going to work in a standard way.

vinci
Paper Tape
Posts: 11
Registered: ‎11-23-2011
Location: Beirut
Views: 2,667
Message 6 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

Never mind. I've installed the bios update again by downloading from the lenovo site and now it seems that the fun has stopped running continuously (I mean, very fast).
vinci
Paper Tape
Posts: 11
Registered: ‎11-23-2011
Location: Beirut
Views: 2,662
Message 7 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

I am sorry for posting for the third time, but I was wrong just now. There's still a problem with my fan running all the time. After entering some programs, browsing around, etc. the fan starts faster and the rpms stay the same. I don't know what the problem is. So, to conclude, I'd appreciate some help.
Thank you
Benik3
Punch Card
Posts: 53
Registered: ‎10-22-2011
Location: Czech Republic
Views: 2,651
Message 8 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

Is there any force methode for installing the same or older bios?

In some installer I could write same switches for force mode.

But this boot program doesn´t supported it (there isn´t command line) :/

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 2,640
Message 9 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

You should be able to downgrade to an older BIOS... At the bottom of the download page, you should see a list of all previously released BIOS installers.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
vinci
Paper Tape
Posts: 11
Registered: ‎11-23-2011
Location: Beirut
Views: 2,604
Message 10 of 75

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

I don't know if you've tried it yet, but you can right click on desktop in order to enter the video card software and there's a button on the upper-right corner "configuration"or sth and you can choose from there 'advanced view' (or sth alike), then you'll see some sections on the left, one of which is choosing how to computer switches between video cards (this is available ofc for e420, e520, etc., so you should have an ati video card and an intel hd integrated card) and you simply choose 'manually' from there and it should work. I have read many posts about the switchable graphics problem, but I can't remember any talk about this simple option in the video card software (ccc, I guess). If you encounter any problems, just post further and I'll try to help.

Check out current deals!


Shop current deals

Top Kudoed Authors