cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vilppueloranta
Paper Tape
Posts: 1
Registered: ‎03-22-2015
Location: Finland
Views: 1,822
Message 51 of 53

Re: E540 Suspend/Resume failure

Thank you for this solution.

 

However, my ThinkPad S3-S440 has the exact same problem but there is not BIOS update released for that model. I have understood that the S440 is a close relative to E440/E540. I am running BIOS version J3ET62WW (1.62 ). The problem occurs with Ubuntu 14.04.2 LTS, Ubuntu 14.10 and Arch Linux.

 

The ThinkPad S3-S440 has Ubuntu certification for model 20AY-Z01NUS (according to Lenovo and Ubuntu sites), however certified BIOS version J3ET29WW (1.06 ) is not available on Lenovo driver sites. My machine is 20AY-001CAT.

 

I would greatly appreciate the same fix also for my model; thank you very much for co-operation.

tsv_dimitrov
Fanfold Paper
Posts: 8
Registered: ‎01-03-2015
Location: Bulgaria
Views: 1,783
Message 52 of 53

Re: E540 Suspend/Resume failure

I flashed the new version and suspend works now. However after resume the ThinkPad led starts blinking sometimes.

In case this annoys you, you can create a file in /etc/pm/sleep.d/ (e.g. 11_led_fix) and put this inside:

 

#!/bin/sh

if [ "$1" = "resume" ]
then
    echo '0 on' > /proc/acpi/ibm/led
fi

 

Overall - great work from Lenovo! I might consider again buying ThinkPad as my next laptop Smiley Happy

Benmhall
What's DOS?
Posts: 2
Registered: ‎11-02-2017
Location: CA
Views: 296
Message 53 of 53

Re: E540 Suspend/Resume failure

Thanks! This trick also worked for me ThinkPad Yoga S1 running CentOS 7. USB 3 would be nice, reliable suspend and resume is better.

Check out current deals!


Shop current deals

Top Kudoed Authors