cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Chasttter
Paper Tape
Posts: 1
Registered: ‎07-27-2014
Location: Slovakia
Views: 338
Message 1 of 1

External HDD not recognized in USB 3.0 [Windows 8]

Hi , few days ago I bought a new Lenovo Thinkpad Edge E540. It has two USB3.0 ports and one USB2.0.

I bought the machine without OS and installed Windows 8.1 Pro(x64) myself. Everything seems to be working fine except when I want to use My WD Elements 1TB external HDD in USB 3.0 port. It just doesn't get recognized. In USB 2.0 port it works fine.

 

What I've gathered and tried so far : 

- Device manager does not show anything not even Unknown Device , yet my USB 3.0 Kingston pendrive works fine out of the box in the same slot 

- I'm pretty sure the USB power is not the issue because the WD HDD , when plugged, starts blinking for a while , then lights up fulltime and i can feel and hear the drive spinning

- I've disabled USB selective suspend in my Power plan

- I've disabled Fast Startup

- In msconfig , im stuck at "Selective startup" (if changed it doesnt even let me APPLY and switches back to Selective right after I close/change tab in msconfig, I tried doing it in safe mode , same thing)

 

 

That's pretty much it , i'll edit if I remember/try something new.

Would appreciate every piece of help regarding this issue as using my harddrive in USB3.0 speed is essential for me and I'm running out of ideas (and google is starting to do so as well).

 

Thanks, Chastter.

Holiday Deals
HAPPENING NOW!

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale

Top Kudoed Authors