Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

5 Posts

06-01-2011

Chita, Russia

32 Signins

36 Page Views

  • Posts: 5
  • Registered: ‎06-01-2011
  • Location: Chita, Russia
  • Views: 36
  • Message 1 of 5

IE8 ignoring first keystroke

2011-06-01, 7:44 AM

Hello,

 

After a lot of research I recently bought a Thinkpad Edge 15 (NVLGQUK) and, apart from being gutted that I have to press Fn before each use of the function keys (I use these a LOT for my job), so far, so good. It seems there's nothing I can do about this inspired Lenovo 'feature' but there is one thing my new machine does which I hope may be cured:

 

When I launch IE8 my system ignores the first keystroke. This is annoying when trying to sign in to web pages. It doesn't seem to do this in Firefox. I can't see that anyone else has experienced similar issues from a web search- has anyone any ideas please? I'm running 64-bit Windows 7 and IE gives its version number as 8.0.7600.16385.

 

Any help would really, really be appreciated!

 

Cheers

 

James

Reply
Options

5493 Posts

04-25-2008

United States of America

39824 Signins

762428 Page Views

  • Posts: 5493
  • Registered: ‎04-25-2008
  • Location: United States of America
  • Views: 762428
  • Message 2 of 5

Re: IE8 ignoring first keystroke

2011-06-01, 9:22 AM

Hi Anglichanin, and welcome to the Lenovo User Community!

 

In the BIOS (press F1 at the ThinkPad logo when the system is starting) you can change the default behavior of the Fn keys.

 

As for your IE 8 missing keystrokes, are your Windows Updates current? There's at least one long thread over at Microsoft on this, with various claimed solutions (keyboard drivers, viruses, anti-virus, ....):

 

http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/internet-explorer-missing-keystroke-problem/1bee2ec3-828c-4a3d-8b05-638e44baf0a8

 

Hope this helps!

 

 

USB-C: Just cos it fits don't mean it works.
I don't work for Lenovo. I'm a crazy volunteer!
Reply
Options

5 Posts

06-01-2011

Chita, Russia

32 Signins

36 Page Views

  • Posts: 5
  • Registered: ‎06-01-2011
  • Location: Chita, Russia
  • Views: 36
  • Message 3 of 5

Re: IE8 ignoring first keystroke

2011-06-01, 10:31 AM

Hi Bananaman,

 

Thanks very much for pointing me in the right direction- I'll certainly try the Microsoft fix.

 

As for the fn keys, I have read other threads on here about it and have already changed my BIOS. However, instead of reverting to a state wherre pressing F1, for example, acts as F1, it seems to have just changed the situation to one where if I press Fn, a black Fn symbol shows on my monitor and then the next keypress of a function key acts as if it were a function key (instead of dimming the screen , muting the sound etc). Perhaps it did this beforehand but I hadn't noticed as I changed the BIOS according to the instructions on here pretty much as soon as I took delivery of the computer.

 

Should the BIOS change have actually swapped the Fn key behaviour so as these keys just perform as normal F1, F2 etc? If I could crack that one I'd be in clover.....

 

Thanks so much for the prompt reply!

Reply
Options

5493 Posts

04-25-2008

United States of America

39824 Signins

762428 Page Views

  • Posts: 5493
  • Registered: ‎04-25-2008
  • Location: United States of America
  • Views: 762428
  • Message 4 of 5

Re: IE8 ignoring first keystroke

2011-06-01, 14:01 PM

Hi Anglichanin!

 

Check Control Panel>Ease of Access Center>Make the keyboard easier to use, and check to see whether you have Sticky Keys turned on.

 

Hope this helps!

USB-C: Just cos it fits don't mean it works.
I don't work for Lenovo. I'm a crazy volunteer!
Reply
Options

5 Posts

06-01-2011

Chita, Russia

32 Signins

36 Page Views

  • Posts: 5
  • Registered: ‎06-01-2011
  • Location: Chita, Russia
  • Views: 36
  • Message 5 of 5

Re: IE8 ignoring first keystroke

2011-06-07, 4:55 AM

Hi Bananaman,

 

Thanks again for the advice but it turns out I had changed the wrong BIOS option. I had changed the Fn Key Lock setting, whereas I actually needed to enable the 'Legacy' setting for the F-keys. This I have now done and my life has become much easier. Thanks again for your help!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms