cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DavetheGray
Paper Tape
Posts: 5
Registered: ‎07-05-2011
Location: UK
Views: 724
Message 1 of 7

Oblivion not loading on Thinkpad Edge E520

Just got a new Edge E520 NZ33MUK , specs here: http://www.saveonlaptops.co.uk/Lenovo_ThinkPad_Edge_E520_1076383.html

 

Having an AMD 6630, one of the first things I wanted to do was try out the gaming ability, so with the system pretty much factory fresh I installed Elder Scrolls IV: Oblivion.

 

Basically Oblivion hangs during loading for me. Specifically It hangs immediately before the tan menu screen appears.

It doesn't say that it's jammed up, and if I ctr-alt-del to task manager it says 'running' i.e. fine, but the screen is just black nothing happening.

 

So far I have tried:

  • Checking all graphics/ audio drivers
  • All different compatibility modes
  • All different graphics setting
  • Set oblivion.exe to high performance (discreet) graphics
  • Disabled User account control
  • Switching graphics to integrated in BIOS
  • Disabling intel graphics in Device manager 
  • Switching to 16bit colour

Any ideas / Anyone in a similar situation?

 

Thanks,

Dave

 

DavetheGray
Paper Tape
Posts: 5
Registered: ‎07-05-2011
Location: UK
Views: 706
Message 2 of 7

Re: Oblivion not loading on Thinkpad Edge E520

Bump. Also I have patched Oblivion with the latest update, still no joy.

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 697
Message 3 of 7

Re: Oblivion not loading on Thinkpad Edge E520

Can you force Catalyst to run it on the discrete card?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
DavetheGray
Paper Tape
Posts: 5
Registered: ‎07-05-2011
Location: UK
Views: 692
Message 4 of 7

Re: Oblivion not loading on Thinkpad Edge E520


@ColonelONeill wrote:
Can you force Catalyst to run it on the discrete card?

Yeah I've set it to High Performance in catalyst if that's what you mean.. still not working.

 

It jams up just as it starts having to render stuff at the game resolution, so I thought it might be to do with the Graphics.

But can't see what else to try.

 

Any other ideas?

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 682
Message 5 of 7

Re: Oblivion not loading on Thinkpad Edge E520

You're currently on the latest Lenovo supplied drivers, right?

Which architecture of Windows 7 are you running?

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
DavetheGray
Paper Tape
Posts: 5
Registered: ‎07-05-2011
Location: UK
Views: 677
Message 6 of 7

Re: Oblivion not loading on Thinkpad Edge E520

I'm running Windows 7 pro 64bit.

 

The Video and audio drivers are all up to date.

The Video driver I'm running is 8.811.1.5000

 

Do you think its a driver issue that might be resolved?

Anybody else able to play Oblivion?

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 672
Message 7 of 7

Re: Oblivion not loading on Thinkpad Edge E520

I'd try updating to the non-Lenovo supported Catalyst drivers:

Go to Guru3D, download the 11.6 Mobility Catalyst for Win7 64-bit. Have it extract to C:\AMD\whatever, but exit out of the Catalyst installer. (You don't want it to nuke the Lenovo customized switchable parts.)

Go to Device Manager, right-click the AMD adapter and choose Update Driver. Browse for the driver manually, and choose "Let me pick...". Click Have Disk, navigate to C:\AMD\11-6-whatever\Packages\Drivers\Display\W76A_INF and choose the INF.

Find the 6630 in the list, and proceed through with the driver install, accepting any notifications. This'll install 8.860 for the AMD card only, which is what we want.

Reboot, and try running Oblivion on the AMD card again.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U

Check out current deals!


Shop current deals

Top Kudoed Authors