cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mrblue751
Blue Screen Again
Posts: 3
Registered: ‎12-28-2013
Location: The Netherlands
Views: 5,007
Message 1 of 12

OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

All,

 

I recently purchased a ThinkPad E531 together with a OneLink dock. The laptop appears to be working just fine. Currently running Windows 8 64 bit.

 

However, the OneLink dock is giving some problems:

 

First of all, the HDMI connection, network interface and USB 3.0 ports seem to be working fine, but...

 

- the audio interface is not working nor is it recognized by Windows (currently I have a simple speakerset connected, but headphones didn't work either and uninstalling / reinstalling the Conextant audio drivers didn't solve the problem).

 

- None of the USB 2.0 ports on the dock are working (they do appear to have power as the light on my WD Passport is blinking when connected). The USB ports on the laptop itself work fine.

 

- When connecting a non-USB 3.0 device to the USB 3.0 ports also these DO NOT work (keyboard, mouse, external HDD with external power, USB stick, none of these)

 

- The OneLink dock tray icon briefly appears when booting showing a status that the dock is not connected (Windows device overview however shows it with status connected through USB 3.0).

 

I've tried removing all USB devices through the Windows deivce manager and reinstalling, updating / reinstalling drivers etc. etc. 

 

I suspect it's either a driver problem or even potentially a hardware issue.

 

Any help / suggestions would be appreciated!

 

 

 

dsalzer
What's DOS?
Posts: 1
Registered: ‎02-26-2014
Location: Portland, Oregon
Views: 4,882
Message 2 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

I'm having similar problems with the ThinkPad Yoga and OneLink Pro Hub.

 

Ethernet and external video work fine.  Can't get keyboard or mouse to be recognized when plugged into the OneLink Hub.  They work fine when plugged into the Yoga itself.

 

When I look at "Devices and Printers", I see "Problem detected with Unknown USB Device (Device Descriptor Request Failed).   Details show:

Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.

When I look at the Driver info for "Unknown USB Device" - the driver version is 6.3.9600.16442 with a Device Date of 6/21/2006.  Seems hard to believe that a 2006 driver would be the right one.  But when I attempt to update the driver it says I have the most up to date version.

 

mrblue751
Blue Screen Again
Posts: 3
Registered: ‎12-28-2013
Location: The Netherlands
Views: 4,865
Message 3 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Dear DSalzer,

 

Lenovo replaced my OneLink dock a few weeks ago. No luck. Conclusion: the problem must be in the laptop.

 

In my case, using Windows 7 or Ubuntu 13.10 instead of the pre-installed Windows 8 (and 8.1) also made no difference. So it looks like a hardware problem...

 

Just last week my latop was collected by Lenovo and is undergoing repair. Curious to see if they are indeed able to repair it and what was the actual problem.

 

I'll update once I have it back.

 

I must say, Lenovo support is not one of the fastest customer support organizations I've dealt with... Things are taking very long and dealing with 1st line support that appears to simply follow a typical script doesn't really speed things up either.

 

 

lapinju
Paper Tape
Posts: 1
Registered: ‎05-23-2014
Location: Germany
Views: 4,622
Message 4 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Hi.

I was wondering if you managed to get the Onelink working properly. I have the same problem (Onelink with Lenovo S440) and running out of ideas. I struggle to set up the operating system again, because of a lot of installed programs.

Cheers

snoshark06
Blue Screen Again
Posts: 13
Registered: ‎08-12-2011
Location: Minneapolis
Views: 3,778
Message 5 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Same issue here. EVERYTHING works except for the audio headphone jack, sound was only coming out of one headphone for a bit, now I can't get it to work at all. 

I've also noticed that the Thinkpad OneLink Dock Detached Icon shows up when I'm attached, and sometimes it's gone completely, even when I have it set to show up all the time. 

- Yes I've tried different headphones (same result)

- Yes I've looked for audio drivers

- Yes I've updated firmware/driver for the dock 

- Yes I've updated bios 

haukla
Paper Tape
Posts: 2
Registered: ‎02-25-2015
Location: Norway
Views: 3,672
Message 6 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Updating to latest firmware solved the issue for me. 

 

Link here: 

http://support.lenovo.com/us/en/documents/pd029981

snoshark06
Blue Screen Again
Posts: 13
Registered: ‎08-12-2011
Location: Minneapolis
Views: 3,666
Message 7 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Lucky!! That didn't fix it for me unfortunately, hopefully they release an update again. 


@haukla wrote:

Updating to latest firmware solved the issue for me. 

 

Link here: 

http://support.lenovo.com/us/en/documents/pd029981


 

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 3,639
Message 8 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Hi Snoshark06,

 

Remove the system from docking station and uninstall the current version audio drivers from the system and shutdown the system. Now connect the one link dock to the system and switch on, after booting to windows run ThinkVantage system update utility and update all the required drivers and application from that, once everything is updated restart the system and check if the issue still persists.

 

Hope this helps.

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

snoshark06
Blue Screen Again
Posts: 13
Registered: ‎08-12-2011
Location: Minneapolis
Views: 3,619
Message 9 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Unfortunately, that didn't solve it for me. Any other ideas? I can't get
the audio jack on the Dock to work to save my life.

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 3,586
Message 10 of 12

Re: OneLink USB 2.0 ports and audio not working with ThinkPad Edge E531

Hi Snoshark06,

 

Have you checked the same dock with other system? 

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Check out current deals!


Shop current deals

Top Kudoed Authors