Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

11 Posts

01-15-2015

21 Signins

102 Page Views

  • Posts: 11
  • Registered: ‎01-15-2015
  • Location:
  • Views: 102
  • Message 1 of 1

Physical buttons on E440 touchpad won't work after coffee spill: capacitive layer works fine

2015-01-15, 21:51 PM

Hi, can you help me with my stupid problem?

 

I have 2 questions:

 

1) Is there a way to enable trackpoint to work with the capacitive layer? I.e. to be able to use it without physically pushing the pad down. Now, as soon as I touch the trackponit, it disables light clicks (touches) of the touchpad, I guess to prevent unintended palm clicks

 

2) Is there anything I can do to make the buttons work again? (See the story below.) I have cleaned it all even inside, but there were almost no stains at all anyway, none on chips or cables. And it partially worked just this morning.

I guess I could soak it in water, then ethanol, and finally dig into rice grains for a week or two as a last resort...but I hope for a more electronics-friendly solution.

 

Story:

I spilled my coffee into the keyboard and touchpad, and even though almost no water got onto the motherboard (a few drops), I cut off the power supply in less than 10 seconds, and I cleaned it all thoroughly (even managed to get inside the touchpad itself and assemble it all back...what a pain), it works weird.

At first, it registered about 1/10 or 1/20 of physical button presses (depressions of the pad). So technically it somewhat worked. The capacitive (touch) layer worked fine including multitouch. Then I tried to just click on it repeatedly for about 100 times rapidly, and it started to miraculously work 100% fine...for about 30 minutes, then it returned to the 1/20 state again. But as soon as it started to work fine, the multitouch recognition died, so it wouldn't scroll etc. And after returning to the bad state again, multitouch was still dead. Then I tried to reinstall the drivers: multitouch has started to work (so scrolling and gestures are OK now). But the physical buttons appear to be absolutely dead at this moment, it won't register any click/depression at all. The capacitive layer works fine though, so I can still use it as a normal touchpad without physical keys.

But this renders trackpoint unusable as it requires physical depressions of the touchpad to register clicks.

 

Thank you very much!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms