Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 4
Registered: ‎06-08-2011
Location: Toronto
Views: 798
Message 1 of 2

Problem with mSATA SSD in E420s - 2013 detection error

I'm trying to install a Samsung 64gb mSATA SSD into my E420s, and encountering the following error:

2103: Detection error on HDD2 (Mini SATA)


System Configuration:


BIOS 1.11

i5 CPU

8gb RAM


I've tried all sorts of combinations of BIOS settings (Legacy/UEFI, AHCI...) and nothing helps.  Am I just out of luck and the E420s is not compatible with this SSD?

Paper Tape
Posts: 5
Registered: ‎12-20-2011
Location: Kansas
Views: 603
Message 2 of 2

Re: Problem with mSATA SSD in E420s - 2013 detection error

im getting the same error with my e220s and a sandisk p4 32gb msata. i've updated to the newest firmware and also messed with the bios settings, i can only get the ssd to boot when the laptop is pluggged into the ac adapter.

Check out current deals!

Shop current deals

Top Kudoed Authors