English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

5 Posts

02-03-2016

Brisbane

11 Signins

134 Page Views

  • Posts: 5
  • Registered: ‎02-03-2016
  • Location: Brisbane
  • Views: 134
  • Message 1 of 11

SmartAudio opens whenever plugging in jack

2016-02-04, 11:30 AM

Hey - on an E560 here, but I'm sure other E series with the Connexant Audio drivers also have this issue - how do we prevent the Connexant SmartAudio from opening and asking us to tell it what type of audio playback device is plugged whenever we plug in a headphone? it's quite annoying and it also pops up when unplugging, and is often unresponsive to clicks.

Reply
Options

5 Posts

05-08-2016

CA

17 Signins

108 Page Views

  • Posts: 5
  • Registered: ‎05-08-2016
  • Location: CA
  • Views: 108
  • Message 2 of 11

Re: SmartAudio opens whenever plugging in jack

2016-05-21, 17:45 PM

I had this problem too, but I believe I've found the solution. Simply download and install the audio driver found here on Lenovo's site: http://support.lenovo.com/ca/en/products/laptops-and-netbooks/thinkpad-edge-laptops/thinkpad-e560/downloads/ds105337 

I installed it just the other day and now the SmartAudio window no longer pops up when I plug in headphones.

 

Edit: it seems I was wrong. The pop-up window came back after a day. Strange, because it stopped appearing immediately after the installation of the driver.

Reply
Options

2 Posts

06-15-2016

EE

9 Signins

81 Page Views

  • Posts: 2
  • Registered: ‎06-15-2016
  • Location: EE
  • Views: 81
  • Message 3 of 11

Re: SmartAudio opens whenever plugging in jack

2017-02-14, 21:45 PM

Hey!

 

I have also had this problem for the whole period of owning an E560 but am yet to discover a solution. Have you guys found something yet?

 

I have tried uninstalling the driver with different results but as it keeps reinstalling with every boot, I am at a loss.

Reply
Options

5 Posts

05-08-2016

CA

17 Signins

108 Page Views

  • Posts: 5
  • Registered: ‎05-08-2016
  • Location: CA
  • Views: 108
  • Message 4 of 11

Re: SmartAudio opens whenever plugging in jack

2017-02-14, 22:21 PM

I'm starting to think that there isn't a solution for this. The laptop uses a multijack that can accept either headphones or a microphone (or even a headset), but is seems that the problem is that it has no way of knowing which one you've plugged in, and so it must constantly ask the user instead. It seems that there's no way of setting a default to assume it's always headphones.

Reply
Options

9 Posts

12-19-2016

US

32 Signins

232 Page Views

  • Posts: 9
  • Registered: ‎12-19-2016
  • Location: US
  • Views: 232
  • Message 5 of 11

Re: SmartAudio opens whenever plugging in jack

2017-02-15, 0:51 AM

I think the answer is here.  "disable conexant smartaudio from device manager, restart your laptop and enable it again." But as you have indicated I am not sure if it will behave properly when you plug in different devices.

 

https://forums.lenovo.com/t5/ThinkPad-11e-Windows-13-E-and/SmartAudio-in-E465/m-p/3378729#M25649

Reply
Options

75 Posts

03-02-2015

US

166 Signins

1694 Page Views

  • Posts: 75
  • Registered: ‎03-02-2015
  • Location: US
  • Views: 1694
  • Message 6 of 11

Re: SmartAudio opens whenever plugging in jack

2017-08-23, 8:14 AM

I've struggled with this issue long time, now it seems like I found definite solution. 

Go to Task Scheduler. Go to Microsoft/Windows/Connexant and DISABLE 'AFA':

 

 

 

Reply
Options

1 Posts

09-21-2017

US

2 Signins

18 Page Views

  • Posts: 1
  • Registered: ‎09-21-2017
  • Location: US
  • Views: 18
  • Message 7 of 11

Re: SmartAudio opens whenever plugging in jack

2017-09-21, 16:03 PM

I just tried this on an E560, and it worked for a little bit, and now it's back. Is this the normal behavior of the program? If so, can they put out a patch to make it stop? I work at a school and the teachers freak out every time it comes up because the program will not go away for them. If you do not choose right then and there, it really is a pain in the butt to get it to close.

Reply
Options

1 Posts

04-23-2018

FR

3 Signins

23 Page Views

  • Posts: 1
  • Registered: ‎04-23-2018
  • Location: FR
  • Views: 23
  • Message 8 of 11

Re: SmartAudio opens whenever plugging in jack

2018-04-23, 19:05 PM

Hi, delete SA2 Scheduler Task Windows.

Reply
Options

9 Posts

12-19-2016

US

32 Signins

232 Page Views

  • Posts: 9
  • Registered: ‎12-19-2016
  • Location: US
  • Views: 232
  • Message 9 of 11

Re: SmartAudio opens whenever plugging in jack

2018-05-01, 23:51 PM

Dell has a clever solution whereby they ask the user to respond and declare a default headphones, headset, microphone so that they won't be bothered every time they plug the device. in. 



I wonder if Lenovo could include this feature in an update. 

Reply
Options

1 Posts

04-13-2018

MY

3 Signins

19 Page Views

  • Posts: 1
  • Registered: ‎04-13-2018
  • Location: MY
  • Views: 19
  • Message 10 of 11

Re: SmartAudio opens whenever plugging in jack

2018-05-17, 4:41 AM

Thanks. I did that on my E470. Disable both AFA and SA2 in the Task Scheduler. So far so good. Smart Audio did not open when I plug in my earphones jack. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete