Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

3 Posts

03-29-2011

2 Signins

14 Page Views

  • Posts: 3
  • Registered: ‎03-29-2011
  • Location:
  • Views: 14
  • Message 1 of 4

System update & restart = USB,WIFI,LAN,AUDIO drivers failed to load.

2011-03-29, 10:44 AM

I have a ThinkPad Edge 13" - before last restart, I used Lenovo System Update and it updated some drivers, not all but incl. some recommended updates- still.. After this restart- even USB, Wifi, Wired, Audio was gone, in Device Manager it says "Windows couldn't load the driver" .. When I click the sound symbol it automatically searches for the driver, finds it, and again it says there's a driverproblem even if it's installed correctly.

Now, as a datatechnician and C# programmer I am getting nervous about two possibilities .. Since I've never visited any dodgy websites or downloaded .exe files.

 

1. It could be a broken Lenovo update (Which I hope)

2. It could be virus, malware, spyware, rootkit or worse ..

 

I've had Security Essentials installed on my PC the entire time ..

 

modelnumber of my edge: NUD2EMD

 

About my EDGE it's been a mixed experience, I do not recognize the quality feel of the usual ThinkPads, the paint is easily worn off the edges just by putting it back/forth in a bag. The Intel WiFi 1000 BGN works OK with some WiFi's, but other some WiFi networks it just won't connect to and always fails connecting or is markable slower at requesting webpages, but not at fetching them. This problem has persisted again and again, even @ home with my LINKSYS WRT54G I'm somtimes thrown off and can never come back on unless I restart my computer. The start-button I've always struggled with, the first press never seems to power ON the laptop, but a second (sometimes harder) press powers it ON and I've never had problems with it not reacting to a second harder press ..

Reply
Options

4417 Posts

01-22-2010

United States of America

38794 Signins

586561 Page Views

  • Posts: 4417
  • Registered: ‎01-22-2010
  • Location: United States of America
  • Views: 586561
  • Message 2 of 4

Re: System update & restart = USB,WIFI,LAN,AUDIO drivers failed to load.

2011-04-01, 15:43 PM

http://www.malwarebytes.org/

 

How about trying a system restore and take it back before all the updates were done.  If that works and everything is back like it was, then download this from the link and let it update and run a quick scan just to rule out any malware.  If all your hardware is back working and you are not able to download malwarebytes, post back.  If you are able to download it and do the scan and nothing shows up, then you can run your system update again and this time don't install everything at once, install one at a time and reboot after each one.  Run your system and make sure there are no problems before you install the next one.

 

The problem with doing a bunch of updates all at once makes it real difficult to determine which one is acting up.  

 

Let's work on getting your system back to normal and then we'll see what's going on with the wireless disconnecting and the problem with the start button.

 

 


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee


Using Browser Search to find your answers in Lenovo and Moto Community
Reply
Options

3 Posts

03-29-2011

2 Signins

14 Page Views

  • Posts: 3
  • Registered: ‎03-29-2011
  • Location:
  • Views: 14
  • Message 3 of 4

Re: System update & restart = USB,WIFI,LAN,AUDIO drivers failed to load.

2011-04-04, 6:19 AM
Unfortunately I don't have 'System Restore' enabled .. I have alot of changing files on several projects and would not like these changes reversed ..

Actually the problem with the start-button has been there since the delivery- it seems like the update broke all drivers incl. the USB hub controller on the motherboard, wifi, wired, audio, and many others ..
Reply
Options

4417 Posts

01-22-2010

United States of America

38794 Signins

586561 Page Views

  • Posts: 4417
  • Registered: ‎01-22-2010
  • Location: United States of America
  • Views: 586561
  • Message 4 of 4

Re: System update & restart = USB,WIFI,LAN,AUDIO drivers failed to load.

2011-04-04, 11:25 AM

Ok, you could try going into device manager, opening a device that isn't working properly, clicking on driver and try to roll back the driver to a previous version.  Hopefully the option isn't grayed out.

 

Have you tried to run malwarebytes yet?   


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee


Using Browser Search to find your answers in Lenovo and Moto Community
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms