cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
solstice
Paper Tape
Posts: 2
Registered: ‎04-08-2013
Views: 307
Message 1 of 2

ThinkPad E530 and the case of the vanished SSD (msata 2101)

(i have updated the title. sounds more like it. ^_^)

 

Greetings !

 

I am a proud (well, yes ...) owner of the E530 A3G-Model sporting a 16GB SSD.

Yes, the one with the pulsy, noisy fan. ^_^

 

 

The Story:

 

Last week i thought i'd need a change and try something new. As i'm not really a noob on

computers, i thought i'd set up Win7 x64 SP1 on the SSD. That's ... not that easy,

considering the size, so i've spent the weekend removing irrelevant components ...

... like Natural Language, Speech Support, Language Packs ...

... from the Win7 x64 SP1 Installation Disks.

 

It took me two days to get it to work, with several testing sessions using VirtualBox,

but then i got it right. I haven't removed any drivers, services or anything actually essential

which could break the system. (I promise!)

 

So ... after a long session in VirtualBox and installing this system on a small partition on my HDD

to verify it REALLY works, i went going on to install it on the SSD.

 

Please note that RapidBoot is turned off in the BIOS and i have removed ExpressCache,

which i had previously installed manually, but wasn't actually caching anything anymore,

for reasons i don't understand. Maybe i have turned it off weeks ago, i don't know.

 

So, i have set up a 3GB FAT32 partition at the beginning of the SSD for the pagefile. It's a habit.

It's a good idea to do this on HDDs, so i kept doing it. Longevity of the SSD was no issue for me,

as if it breaks ... well, then it breaks ... but then it would break in honor, having served me well.

 

The rest of the SSD got partitioned NTFS, for Win7 x64 SP1, which installed *successfully*.

The installation process went *flawlessly* and it also ran *flawlessly*.

 

So ... i've started installing drivers from my HDD, which are all in this nice SWTOOLS folder,

onto the SSD. Easy cheesy, clicked through the symbols in my Device Manager and let it

run through the folder, to update the drivers.

 

The first odd thing i've noticed was that, after establishing an internet connection,

the ThinkPad PM Driver got named into Lenovo PM Driver. Okay, well, so be it, i thought.

 

All drivers actually installed smoothly. No issues. Nothing. Reboots worked. All good.

 

Then ... i've started Windows Update. I have done this in the VirtualBox so i knew there were

quite a lot updates to be downloaded (around 280MByte) ... but it didn't get very far.

 

 

Here it starts:

 

The green bar, which indicates searching, kept pulsing. The visible windows were all stuck,

but the mouse still could be moved. I thought ... okay ... that's odd ... but left it for a few minutes.

As nothing changed for 10min, i've reset the system. That may not have been a smart thing to do,

but as not even the Task Manager came up, it was the *only choice i had*.

 

Now ... i can't recall if the 2101 Error displayed at this time already, but i can recall having tried to

boot into the OS on the SSD again and it took ages. Ages. After 5min watching the pulsing

Windows ButterFly, i thought "Okay, that's odd" and reset the system.

 

(Actually, after i have written the whole post, i'm not sure anymore if i actually tried

booting onto the SSD now, or if the error came up already. I'm sorry for this lack of memory,

it was past 0100am.)

 

 

In hindsight, i know i should have waited longer, but that may not actually

have changed anything. Now i'll never know.

 

So ... after this reboot ... Lenovo Boot Splash Screen ... BEEP ... msata 2101 blabla HDD2 not found etc.

F***! Okay ... no worry ... let's see. Booted into the HDD OS ... the pulsing butterfly again ...

... waiting ... waiting ... waiting ... waiting ... okay i'll have a smoke ... 5min later ... the login sound.

 

I know this kind of waiting. It's the waiting that happens when a driver delays everything,

for reasons only the driver knows, unwilling to share it with the user.

 

So ... finally, the HDD OS booted up. I'm glad. I log in ... and wait. BlackScreen. Wait. Wait.

Desktop comes up. System is heavily unresponsive.

 

I'm starting the Task Manager. Waiting. It starts.

Show all processes.

"System" is at 25%, indicating it's hogging a CPU core ... for unknown reasons.

 

I open up the Device Manager.

One Exclamation Mark on Yellow Background:

Lenovo PM Driver.

 

I run the Windows Please-Help-Me-And-Find-Out-What's-Going-On-Program.

 

It suggests updating the driver ... so i tried updating the driver via Windows Update ... and it did.

 

Now ... i have *no* idea where that issue comes from and updating the driver did not help at all.

Right now, the exclamation mark again is present, so i simply *deactivated* it in the Device Manager,

but haven't rebooted yet. The PC is still running and i doubt it'll have a serious impact. I already deleted

it from the Device Manager once, just to see it get reinstalled.

 

So ... this is the whole story, in right order. Complete.

 

Windows Update, for some odd reason, broke something. I doubt the reboots are part of this,

but there may be a first time for anything.

 

 

In the now:

 

I have googled this extensively, within limited options regarding search terms. I have removed the SSD

and plugged it in again, but it changed nothing. I am researching on how to find the one driver which

causes the boot delay (which only happens when the SSD is plugged in, btw), which - i hope - gives

me more options ... but as of yet, i'm still researching. I might try bootvis, because i know it does stuff like that.

 

 

So ... after telling you my story (hope you had a nice read and you're at work, wasting your time ^_^),

if there is ANYBODY OUT THERE who knows **bleep** is going on, I'd REALLY appreciate ANY advise !

Except: unplug the SSD and forget it. That's not an option. ^_^

 

 

Thank you for your time, i hope you like detailed posts about malfunctions happening. Smiley Happy

solstice
Paper Tape
Posts: 2
Registered: ‎04-08-2013
Views: 294
Message 2 of 2

Re: ThinkPad E530 and the case of the vanished SSD (msata 2101)

Oh ... i forgot to mention that the 2101 error doesn't even show up anymore. Smiley Happy

Check out current deals!


Shop current deals

Top Kudoed Authors