cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
thinkpadE570Use
Paper Tape
Posts: 2
Registered: ‎10-29-2018
Location: US
Views: 317
Message 1 of 1

Thinkpad E570 not working after BIOS update through Lenovo Vantage

Hi,

I chose the recommended BIOS updates on lenovo support page. After starting the bios updates the computer automatically shut down and stayed shut down for 5 min (AC charger was plugged in all the time). I tried to turn it back on but it didn't turn on /boot. Only the LED in power button and caps lock button are green. I tried below things, nothing worked yet-

1. Removed the battery and tried turning it on only on charger

2. Held the power button for 30 seconds with AC charger and battery removed and then tried turning it on

3. Opened the back and unplugged the CMOS cell battery plug for 15 mins, plugged back in no luck

4. Downloaded "BIOS Update (Bootable CD) for Windows 10 (64-bit), 7 (32-bit, 64-bit) - ThinkPad E470, E570" from lenovo burned onto a dvd using another laptop and tried to boot the laptop with issues, no luck.

 

Please help as I desparetely need this fixed. Thanks

Check out current deals!


Shop current deals

Top Kudoed Authors