cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tephlon
Paper Tape
Posts: 3
Location: SE
514 Views
Message 1 of 5

Touchpad and trackpoint dead with bios 1.17 on Linux

Hi!

 

I have an E460 laptop, on which I'm dual booting Windows 10 Pro and Manjaro Linux (basically Arch Linux) with Linux kernel 4.5.2.

 

Having the same problem that people discuss in the E460 Keys repeating when pressed for 3 seconds thread, I have been bumping my bios to 1.13, 1.16, and yesterday, to bios 1.17, to see if the problem had been resolved.

 

With the 1.17 bios update, my touchpad and trackpoint stopped working in Linux (In Windows they work fine). They do not even show up in /dev/input, and there is no mention of either of them in dmesg, journalctl, /var/log/Xorg.0.log, or anywhere.

 

The touchpad and stick worked fine in bios 1.13 and 1.16, so I'm thinking there is some regression in 1.17.

 

Is anyone else experiencing this? Can Lenovo confirm whether there is a problem?

 

 

Guru
Guru
Posts: 1,300
Location: US
493 Views
Message 2 of 5

Re: Touchpad and trackpoint dead with bios 1.17 on Linux

Have you tried to reset your BIOS settings to default? Then try again.

Jonas


Lenovo Insider
Microsoft MVP Windows Development


Twitter: @jonashendrickx

tephlon
Paper Tape
Posts: 3
Location: SE
484 Views
Message 3 of 5

Re: Touchpad and trackpoint dead with bios 1.17 on Linux

Thank you, jonas_hendrickx, that was the trick! I had not tried resetting the bios to default settings. Doing that, and it the touchpad and trackpoint are with me again.

 

Thank you! Smiley Happy

 

 

 

 

 

 

 

 

v_plagov
Paper Tape
Posts: 3
Location: NA
415 Views
Message 4 of 5

Re: Touchpad and trackpoint dead with bios 1.17 on Linux

Hi,

 

Could you please advise how to reset BIOS settings to default? I have installed Ubuntu 16.04 64-bit on a brand new ThinkPad E460, but botht touchpad and trackpoint don't work at all...

tephlon
Paper Tape
Posts: 3
Location: SE
380 Views
Message 5 of 5

Re: Touchpad and trackpoint dead with bios 1.17 on Linux

While booting, hit Enter to enter the boot menu. Select to enter the BIOS. In there is a setting to revert to the default settings.

Please note that you might have to (re-)disable Safe Boot, and/or change (back) your boot order to something that works for you. I had to do that, but then you are using Ubuntu, so it might work anyway.
Top Kudoed Authors