English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

1 Posts

06-02-2015

Australia

9 Signins

91 Page Views

  • Posts: 1
  • Registered: ‎06-02-2015
  • Location: Australia
  • Views: 91
  • Message 1 of 2

Yoga 11e (20D9) Touch Screen NOT Working or Responsive

2015-06-05, 4:13 AM

I bought this Yoga 11e (20D9) in December 2014 and Windows 8.1 was installed as default.

From last Friday, 29th May 2015, touch screen has stopped responding totally.

For six months, there was no fall or damage or even a scratch in / outside of the laptop.

 

After trying all the possible suggestions found in this forum and the other web sites, I have reset it to factory default - fully removed everything and installed Windows. And then all the Windows Updates and also Lenovo Updates completely. Still the touch screen is not working or responsive at all.

 

I think I did all things I can try. Now I am about to claim warranty service.

Last Decempber, I decided to buy this Lenovo products which I had believed as the most reliable laptop, but it does not have  that much good quality after all.

Reply
Options

3 Posts

05-05-2016

US

2 Signins

18 Page Views

  • Posts: 3
  • Registered: ‎05-05-2016
  • Location: US
  • Views: 18
  • Message 2 of 2

Re: Yoga 11e (20D9) Touch Screen NOT Working or Responsive

2016-05-05, 23:31 PM

I had the same problem.  After performing a clean-install of Windows 10 Pro (Did not like all that blotware that Lenovo puts in these systems) and "thinking" that I had installed all drivers, I found that touchscreen did not work.  I solved it by RE-installing the i2c drivers (downloaded from Yoga 11e support page).  It was confusing because there was nothing in Device Manager that indicated any drivers were missing, plus when I ran the .exe file for the i2c drivers all it did was "extract" the files, but it did not install anything!

So here is how I went about it:  Opened device manager, clicked on "system devices" to locate the i2c device.  I looked for anything with "i2c" in it, and saw 2 entries: "Intel Atom Celeron Pentium Processor............i2c........[etc, etc]".  I went ahead and manually installed the drivers: right-clicked the item, clidked "update driver software", clidked "browse my computer for driver software", and navigated to where the driver files had been extracted to-as explained above.  After the drivers were installed successfully, the names of the devices changed to "i2c controller".  Rebooted the computer and VOILA! The touch screen worked again! 

Opened "control panel", "system" and there it said: "Touch Support With 10 Touch Points"

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save