Showing results for 
Search instead for 
Do you mean 
Paper Tape
Posts: 10
Registered: ‎09-20-2011
Location: Israel
Message 1 of 2 (360 Views)

e420s 4401-4ng - cant install catalyst and use the 6630 :-\



i just baught lenovo e420s with gpu radeon 6630m 2gb


first of all,

ive been trying to install the catalyst from amd website. after downloading, it says the program is incompatible with my system. then, i used their service of exploring my system and chosing the right installation for me - the same error showed.


second of all,

ive been trying to use the 6630 graphic card, with no success. i went to the device manager, trying to disable the intel, but then the resolution is REALLY low.


how can i fix these issues????



Former Employee
Posts: 2,437
Registered: ‎04-10-2011
Location: Malaysia
Message 2 of 2 (310 Views)

Re: e420s 4401-4ng - cant install catalyst and use the 6630 :-\

hey roncohe4,

have you tried the drivers from the Lenovo Support site : ?

If you have, could you tell us if there was any issue using the graphic drivers that was provided there?

WW Social Media
Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

Follow @LenovoForums on Twitter!
Have you checked out the Community Knowledgebase yet?!
How to send a private message? --> Check out this article.
Top kudoed Authors