cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
_ism
Ctrl-Alt-Del
Posts: 5
Registered: ‎11-03-2018
Location: US
Views: 408
Message 1 of 7

"Secure Boot Disabled" message when attempting to dual-boot

So I recently upgraded my e485 to a 512GB SSD instead of the stock HDD that the model that I purchased came with.  Prior to this upgrade, I'd easily been able to create a dual boot both Windows 10 and Arch linux. However, after changing the SSD out and re-installing Windows 10, I can't even boot into Arch's installation media.  I'm left with a black screen and a single line of text that says "Secure Boot Disabled" and nothing else (picture below). From this screen I am unable to further load the installation media, reset back into BIOS, or anything else unless I hard-reset and try to start again.

The installation media I created was made using Rufus ver.3.3 both times, and I have attempted every variant of Secure Boot off/on, CSM off/on with UEFI-only, Legacy-only, both enabled with both UEFI and Legacy primary, GPT vs. MBR-formatted installation media, even going so far as to using other distros of Linux and nothing seems to change. With Secure Boot on the BIOS will skip my installation media entirely and load straight into Windows 10.  I have already created an unallocated partition with which to install Arch.

Picture of aforementioned screen:
20181103_233212.jpg

Social Support Agent
Social Support Agent
Posts: 96
Registered: ‎08-02-2018
Location: US
Views: 377
Message 2 of 7

Re: "Secure Boot Disabled" message when attempting to dual-boot

Hi _ism!

 

Welcome to the community forums,

 

From this article: https://wiki.archlinux.org/index.php/Dual_boot_with_Windows?linkId=59150324

 

"If Arch and Windows are dual-booting from same disk, then Arch SHOULD follow the same firmware boot mode and partitioning combination used by the installed Windows in the disk."

 

Can you try the following:

1. Boot into the BIOS then under the restart tab, select Load Setup Defaults then set OS Optimized Defaults to Disabled.

2. Disable Secure Boot under Security Tab then press F10 to save and Exit

3. Boot from your Win10 installation media then press Shift+F10 to open a command prompt then type:

- diskpart

- sel disk 0 (where disk 0 is your SSD drive)

- clean

- convert gpt

- create partition primary

- exit

- exit

4. Install Windows on the unallocated partition.

5. After booting Windows, open Disk Management and Shrink the SSD drive to your desired space to install Arch Linux.

6. Boot from the Arch Linux installer then see if you can now install it for dual boot.

 

Regards,

 

 

Admin note: link shortener converted to full URL for clarity



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

_ism
Ctrl-Alt-Del
Posts: 5
Registered: ‎11-03-2018
Location: US
Views: 301
Message 3 of 7

Re: "Secure Boot Disabled" message when attempting to dual-boot

I've attempted all of the aforementioned and have not managed to fix the issue.  However, when creating an install USB with an NTFS file system, an MBR partition scheme, and booting off of "Legacy First" in BIOS boot options it will actually pass the "Secure Boot Disabled" screen and proceed into the installation media, however under this scheme I am unable to install the necessary EFI utilities to complete the install.

_ism
Ctrl-Alt-Del
Posts: 5
Registered: ‎11-03-2018
Location: US
Views: 297
Message 4 of 7

Re: "Secure Boot Disabled" message when attempting to dual-boot

in addition to this, I can get into the Arch installation media with a GPT/NTFS installation media as well, but it will only allow me to select "boot into firmware interface" aka go back to BIOS. This seems to be a problem with trying to format the install media as FAT32.
dcbbleo
Fanfold Paper
Posts: 21
Registered: ‎10-20-2018
Location: CA
Views: 288
Message 5 of 7

Re: "Secure Boot Disabled" message when attempting to dual-boot

Since you mentioned having used Linux on the laptop before, I'm assuming you know about the iommu issue affecting e4/585 laptops? I'll mention it here just in case: pass the parameter "iommu = soft" to the kernel before booting.

 

Otherwise... 

 

Is your Windows installation working / booting properly? Make sure you're ssd is partitioned as gpt.

 

If so, it could just be the way you are creating the media. I haven't used Rufus, and I usually create my media by just writing the iso to a flash drive using dd, but I have used Universal USB Installer which worked in the past.

 

Ubuntu and OpenSuSe worked for me even with secure boot enabled. From what I can see Arch shouldn't have a problem either.

 

_ism
Ctrl-Alt-Del
Posts: 5
Registered: ‎11-03-2018
Location: US
Views: 283
Message 6 of 7

Re: "Secure Boot Disabled" message when attempting to dual-boot

Yes, specifically I had been using the workaround of "ivrs_ioapic[32]=00:14.0," because for whatever reason grub on my old HDD initially didn't seem to care for iommu=soft, and the problem here is it's not even allowing me to get to the main screen of the install media where one would normally input those settings at kernel boot.  And yes, the installation is working perfectly fine and I can boot into the arch install media by using "Legacy First" in the UEFI options and loading off of that, but in doing so I'm unable to access the necessary EFI utilities to get grub to install everything correctly.  Rufus may be the issue, although as I mentioned in the original post it worked on my old HDD.

_ism
Ctrl-Alt-Del
Posts: 5
Registered: ‎11-03-2018
Location: US
Views: 215
Message 7 of 7

Re: "Secure Boot Disabled" message when attempting to dual-boot

Adding more absurdity to this problem, my Arch install media has started booting when Secure Boot is enabled but I'm still presented with the same "Secure Boot Disabled" freeze screen.

Check out current deals!


Shop current deals

Top Kudoed Authors