Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Blue Screen Again
Posts: 1
Registered: ‎08-02-2011
Location: Phoenix, AZ
0 Kudos

Display Issue with my Thinkpad Edge 13 (I believe)

[ Edited ]

I recently started experiencing a severe graphical glitch on the left of the laptops screen. It looks like a Big white rectangle with red on the bottom edge and green lines on the left and right sides.

I believe it to be a screen hardware issues. Since when I tap on the back side lightly, it moves and causes the lines to flicker. My laptop I believe is still under warranty and I think Lenovo should fix it.

What do you guys think?


Also, my laptop also heats up really hot sometimes even under light to moderate use. Is that just part of a laptop growing old? Or might it just need to be opened up and dusted? Can you even do that with an Edge, and still put it back together?

Posts: 8,395
Topics: 422
Kudos: 1,456
Solutions: 328
Registered: ‎11-19-2007
Location: RTP, North Carolina
0 Kudos

Re: Display Issue with my Thinkpad Edge 13 (I believe)



Welcome to the forum - sounds like you have a few issues here...


1) Running warmer... Check power manager to be sure latest version is installed - sometimes things get corrupted.  You can also blow out the fan with the system off.   Ideally, fan and heatsinks are cleaned with the system opened up, but as you are under warranty, let's hold off on that.


2) Video issues.   Tell us a bit more if you can...


If you move the lid back and forth, does this change?  If so, it is likely an issue with the display cable.  The cable could be damaged / pinched, or it might not be making a good connection.


If you hook up an external display, does the same image result on the external display?  If no, then back to the LCD internal cable, or less likely, an issue with the LCD itself.   If on the other hand, the image defects exist on the external display same as the internal, then likely it is:


a) Corrupt video drivers - uninstall / reinstall the newest ones from the support site

b) memory - power down the system and open the memory compartment - remove and reseat the memory module(s)

c) Run diagnostics (Thinkvantage Toolbox) and run the video tests.  If it fails, definitely call support.


If you have been through all of the above and are still stuck, give support a call since you are under warranty.


Best regards,




ThinkPads: S30, T43, X60t, X1, W700ds, IdeaPad Y710, IdeaCentre: A300, IdeaPad K1
Mark Hopkins
Program Manager, Lenovo Social Media (Services)
twitter @lenovoforums
English English Community   Deutsche Deutsche Community   Español Comunidad en Español   ru.gif Русскоязычное Сообщество