Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Highlighted
Blue Screen Again
Posts: 4
Registered: ‎12-18-2011
Location: Germany
0 Kudos
Accepted Solution

E320 Fn-Keys not working

Hi,

 

I just bought a Lenovo E320 laptop with 128GB SSD w/o OS. I installed Win7 Pro 64x from a USB drive and every driver from the lenovo support site that seemed sensible. Including chipset, video, network drivers etc. I also installed UltraNav Drivers and "Hotkey Integration" for Windows 7.

But most of the hotkeys don't work. Volume +/-/mute (Fn + F1-3) and brigtness (F7-8) work, but the others don't. Pressing Fn+F9 for wireless connections doesn't yield any reaction. Plus when I'm changing brightness or volume there is no indication of the new brightness/volume value on the screen. I can start TPOnScr.exe from "Hotkey Integration" but still no effect.

I also installed ThinkVantage System Update device and had it check for anything that might be missing. It only brought up a couple of Win7 updates and bluetooth drivers. But I can't activate bluetooth because Fn + F9 doesn't do anything.

Does anyone have a clou what I'm doing wrong? Oh and I changed function keys settings in bios to "legacy" so that I have to press FN to access the hotkeys. Just to avoid any confusion.

 

Oh and there is another thing: The device manager shows an unknown device which I can't seem to identify. Any hints what that could be?

 

Regards,

 

David

Retired Employee
Posts: 2,437
Registered: ‎04-10-2011
Location: Malaysia
0 Kudos

Re: E320 Fn-Keys not working

hey Cubic00,

welcome to the forums.

try uninstalling the software and before you install it, set your unit to diagnostic mode first via msconfig before installing.

also if your bios is less than version 1.16/1.15 ; do update it.





WW Social Media
Important Note: If you need help, post your question in the forum, and include your system type, model number and OS. Do not post your serial number.

Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!



Follow @LenovoForums on Twitter!
Have you checked out the Community Knowledgebase yet?!
How to send a private message? --> Check out this article.
Blue Screen Again
Posts: 4
Registered: ‎12-18-2011
Location: Germany
0 Kudos

Re: E320 Fn-Keys not working

Hello again,

 

the bios has already been updated. But I found a solution that is probably pretty similar to yours. I uninstalled "Hotkeys features integration" and installed ThinkVantage System Update device and had it install everything again. Looks like I missed to install Thinkad Power Management software. Now everything is alright.

 

Thanks for the help and bye.