Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Blue Screen Again
Posts: 4
Registered: ‎01-23-2012
Location: United Kingdom
0 Kudos

E520 Bluetooth after fresh Windows install

[ Edited ]

Hi Everyone,

 

Today I installed a new SSD into my mSATA slot and as such needed to installl windows 7 onto it, rather than my hard disk. As I couldn't figure out how to do this using the Lenovo recovery, I borrowed a windows 7 CD and put a fresh install onto my SSD, before reformatting the HD.

 

Everything has worked perfectly, except that my bluetooth chip no longer apppears in device manager and if I try to install the drivers from the Lenovo website it doesn't detect my chip and won't install.

 

It is definitely turned on in BIOS and as far as I can tell there is no hardware switch that needs to be changed. If I open the hotkey program for wireless  it only displays my Wifi (I think bluetooth used to be in it?)

 

Any help would be much appreciated.

 

(On a side note, is there any way to email/chat to Lenovo support directly?)

 

Jamie

Punch Card
Posts: 11
Registered: ‎01-09-2012
Location: Slovakia
0 Kudos

Re: E520 Bluetooth after fresh Windows install

Hello,

 

I remember having no bluetooth in Device Manager after clean install myself.


jamiefish wrote:
If I open the hotkey program for wireless  it only displays my Wifi (I think bluetooth used to be in it?)

Yes, bluetooth should appear in Individual control. Did you install Intel Chipset Device Software? Though I'm not really an expert, it may help Windows 7 to recognize the device.

 


(On a side note, is there any way to email/chat to Lenovo support directly?)


I've never tried that but here are some phone numbers...

Blue Screen Again
Posts: 4
Registered: ‎01-23-2012
Location: United Kingdom
0 Kudos

Re: E520 Bluetooth after fresh Windows install

I hadn't but have no and still no luck unfortunately. I managed to install the drivers by finding a different exe but again, no luck. The bluetooth helper won't start at all.
Highlighted
Punch Card
Posts: 11
Registered: ‎01-09-2012
Location: Slovakia
0 Kudos

Re: E520 Bluetooth after fresh Windows install

Hi again,

 

Honestly, don't know. Allowing BT via the Wireless Radios program is pretty much a standard procedure and can say it worked for me back then. I would try to reinstall Hotkey Features Integration.

 

Good luck.

Blue Screen Again
Posts: 4
Registered: ‎01-23-2012
Location: United Kingdom
0 Kudos

Re: E520 Bluetooth after fresh Windows install

Thanks for your help. It worked in a live Ubuntu so its not a hardware problem, will call them tomorrow for more assistance...

Paper Tape
Posts: 5
Registered: ‎04-19-2012
Location: Breza
0 Kudos

Re: E520 Bluetooth after fresh Windows install

Do you have "access connection" installed?

Lenovo Employee
Posts: 75
Registered: ‎04-23-2008
Location: Maryland
0 Kudos

Re: E520 Bluetooth after fresh Windows install

[ Edited ]

Press F9 and turn on bluetooth under "Individual Control"

Although my Avatar shows me as a Lenovo Employee, which I am, I am not a support professional so any help I offer here is as a fellow user.