Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Highlighted
Punch Card
Posts: 50
Registered: ‎10-22-2011
Location: Czech Republic
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

[ Edited ]

What is the connection with fan?

Maybe this topic will be better for you: http://forums.lenovo.com/t5/ThinkPad-Edge/E420s-switchable-graphics-with-opengl/td-p/522927/highligh...

Punch Card
Posts: 50
Registered: ‎10-22-2011
Location: Czech Republic
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

New bios here (1.22). I tried him, it looks that it work, but now the fignerprint doesn´t wok!

**** it!

Lenovo Staff
Posts: 3,568
Registered: ‎07-11-2010
Location: Malaysia
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

@Benik3,

Try uninstalling the fingerprint reader driver, reboot the laptop then install the driver again and see if it helps.

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




X240 | 8GB RAM | 512GB Samsung SSD

Punch Card
Posts: 27
Registered: ‎11-22-2011
Location: Poland
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

I would like to pay attention to this issue !

My E420 sometimes gets quite hot and fan doesn't work. I have to manually switch graphics (doesn't matter from which to which)  to make ventilation system work! When I launch a game, fan starts working, but in desktop, when something make system hotter, fan stays off. Rebooting system also helps, but I use hibernation & sleep modes for most often. BIOS upgrade needed, please get to work on this problem.

Punch Card
Posts: 50
Registered: ‎10-22-2011
Location: Czech Republic
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

I tried install back v1.20 and still have the problem with fan. It looks, that it isn´t problem with bios, but with drivers Smiley Sad
Lenovo Staff
Posts: 3,568
Registered: ‎07-11-2010
Location: Malaysia
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

@Gregi and Benik3,

Ensure you have Lenovo Power Manager and Power Management driver installed.

//JameZ

Check out the Community Knowledge Base for hints and tips.


Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!




X240 | 8GB RAM | 512GB Samsung SSD

Punch Card
Posts: 27
Registered: ‎11-22-2011
Location: Poland
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

[ Edited ]

JameZ wrote:
@Gregi and Benik3,

Ensure you have Lenovo Power Manager and Power Management driver installed.

//JameZ

Of course I have, always.

ThinkPad Power Management Driver (1.64.00.00) installed

ThinkPad Power Manager (3.64) installed

 

They are latest.

Punch Card
Posts: 50
Registered: ‎10-22-2011
Location: Czech Republic
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

Me too.

bss
Paper Tape
Posts: 7
Registered: ‎12-28-2011
Location: Slovenia
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

I have the same problem with the fan. I have notieced if i switch off the discrete graphics, fan speed will stay as it was in the moent i switched the ATI graphics card off. So if the cpu had some load and the fan speed went up and I switched the discrete draphics off, the fan speed would stay the same - running on high rpm. 

 

On linux I've also noticed that some kind of system temperature is not changing if the discrete graphics if off, thus fan speed not changing - as the system don't notice the change in the temperature.

 

I still have 1.19 bios version. Do you suggest I update to the newest? Does anyone know if it resolves this issue?

 

Regards!

Punch Card
Posts: 50
Registered: ‎10-22-2011
Location: Czech Republic
0 Kudos

Re: E520 Fan sometimes not working after switchable-graphic- issue-BIOS-Update

The bios update don´t solve it. I tried v1.20 and 1.22 and it was still the same Smiley Sad