Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos
Accepted Solution

E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Photoshop CS5.5

I'm having a problem using the "Advanced" OpenGL setting in Adobe Photoshop CS5.5. While I can select "Advanced" as an option, none of the advanced features are available to use (like flick panning and animated zoom). 

 

I've updated my system with the latest video drivers (8.840.7.3000/6.14.0.3074) and BIOS (1.22/1.10/1.02), however, that's not working. 

 

The video drivers packaged on the Lenovo site aren't the latest listed on the AMD site for the 6630M and I can't update my system with drivers from the AMD site. 

 

This is a real issue for me since I bought the laptop as a design production machine and can't utilise the graphics card to its full potential. I wrote to AMD to ask them, which resulted in them pushing it back as Lenovo issue. 

Fanfold Paper
Posts: 7
Registered: ‎01-28-2012
Location: uk
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

hi

have you tried manually changing the graphics from the intel graphics to the amd graphics becuase the graphics doesnt automatically switch to the high performance gpu with opengl.

Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

I have the machine's power options set to "Maximum Performance", with switchable graphic set to "Select GPU based on power source", where the machine is plugged in and the selected GPU is the "High Performance GPU", AKA the AMD 6630M card. 

 

I've tested it with Cinebench and with Google Earth in Open GL mode and it works well, its just Photoshop that's not utilising the card properly. 

Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

bump

Fanfold Paper
Posts: 7
Registered: ‎02-06-2012
Location: UK
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

Try manually changing the grpahics to High End manually

Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

I'm not sure what you mean. I've already set the graphics to high performance. The power switchable graphics method is set to choosing the graphics card based on power source, which is through the AC adapter. It states that the card being used is the ATI card. I've tested with Cinebench and Google Earth (Open GL) and it works fine. Its just Photoshop that is not playing ball. 

 

The Adobe site states that the card is supported, therefore its an issue with the drivers which I can't update because they have to come from Lenovo. CCC v12.1 is out already with new drivers and I can't update the card to test the issue. 

 

Catalyst Control Centre and Photoshop both indicate that the 6630M card is being used. I know this isn't the case for Photoshop because the advanced Open GL features are not working. 

 

 

Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

Further investigations points to the drivers and specifically the 11.6 drivers not working with Photoshop

 

http://support.amd.com/us/kbarticles/Pages/AMDCatalyst116ReleaseNotes.aspx

 

I really need the updated drivers Lenovo. Please escalate. 

Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

bump
Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

When are the drivers for the 6630M going to be bundled and released? I need the new drivers.
Highlighted
Serial Port
Posts: 16
Registered: ‎01-26-2012
Location: Australia
0 Kudos

Re: E520 w/ 6630M 2GB card won't work correctly with "Advanced" OpenGL setting in Adobe Ph

Update: Latest driver update (8.882.2.3000 / 6.14.0.3074) fixed problem
http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS014099