Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

1 Posts

10-09-2020

Germany

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎10-09-2020
  • Location: Germany
  • Views: 5
  • Message 1 of 4

Bios update 1.12 for L14 (AMD) is broken

2020-10-09, 19:58 PM

Bootup time for windows 10 was like 10 sec before

Now a full boot takes about 3 minutes (bios 1.12)

 

did a complete driver update via windows and amd, nothing changed

windows event log does not contain any errors

i also tried to disconnect every external device

 

can i revert back to old bios?

Reply
Options

5 Posts

09-02-2020

Germany

4 Signins

35 Page Views

  • Posts: 5
  • Registered: ‎09-02-2020
  • Location: Germany
  • Views: 35
  • Message 2 of 4

Re:Bios update 1.12 for L14 (AMD) is broken

2020-10-09, 22:50 PM

Same here + my main OS (PopOS) doesn't even boot anymore. Cann't even boot any system which uses Systemd boot anymore.Seriously never going to buy crap from Lenovo again. I cann't play games with this notebook because It will freeze completely. I have a white dot in the middle of the screen. And now this BIOS **bleep** with NO answer from Lenovo. Seriously LENOVO when I pay premium prices I expect okish support not that **bleep**show you provide with the L14. **bleep** you seriously.

Reply
Options

18 Posts

09-02-2018

Germany

40 Signins

316 Page Views

  • Posts: 18
  • Registered: ‎09-02-2018
  • Location: Germany
  • Views: 316
  • Message 3 of 4

Bios update 1.12 for L14 (AMD) is broken

2020-10-13, 7:04 AM
Yes, there is a setting in BIOS to enable rollbacks. After setting it correctly, flash the old BIOS.
Reply
Options

6 Posts

10-18-2020

United Kingdom of Great Britain and Northern Ireland

8 Signins

70 Page Views

  • Posts: 6
  • Registered: ‎10-18-2020
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 70
  • Message 4 of 4

Re:Bios update 1.12 for L14 (AMD) is broken

2020-10-19, 6:54 AM

Same here, but it went away. Also with systemd-boot not booting. I think it somehow related to an AMD Radeon driver (non-WHQL), and I rolled it back. But, I may be completely wrong.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms