English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

4 Posts

10-18-2020

GB

5 Signins

55 Page Views

  • Posts: 4
  • Registered: ‎10-18-2020
  • Location: GB
  • Views: 55
  • Message 1 of 4

L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-19, 5:20 AM

Hello, there seems to be a problem with my new L14 Thinkpad  (model 20U50001UK). The fan starts to spin at a certain temperature, then it spins faster when a threshold is reached, and faster, but never goes back to lower speeds. It is now noisy until I power off the machine and restart it (reboot doesn't solve the issue). 

 

It is probably not a hardware issue because:

  • The temperature sensors seem fine. It is only the fan speed deceleration that does not work. E.g. after a heavy load the fan continues to spin at high rate, even at 45 degrees C.
  • If I click on 'battery optimised' in the AMD power slider, it is the (only) way to get it temporarily back once it peaked to a higher speed. But this is not a workaround to me, because I want to use linux and also I want to use the full potential of the CPU.
  • I read similar threads of earlier Thinkpad models that had a similar issue fixed with a BIOS update. 

 

Shall I wait for a BIOS fix or return it? I really liked this thinkpad, but I am afraid if I get a replacement it will have the same issue, unless the BIOS is fixed as soon as possible... Does anyone else have the same issue or is it isolated?

 

Thanks

Reply
Options

1234 Posts

03-11-2020

NO

144 Signins

6636 Page Views

  • Posts: 1234
  • Registered: ‎03-11-2020
  • Location: NO
  • Views: 6636
  • Message 2 of 4

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-19, 10:50 AM

Hello Philippos,

 

 

Does the fan operate the same when in the Windows environment ? If not, and they operate normally, then it's a good conclusion that this has to do with some un-compatible drivers in Linux. 

All one can do is wait for an update, or hope that some Linux guru finds a work around.

 

Meanwhile, you could make sure your system board is up to date:

 

Updating the Chipset and Thermal Solution Drivers  

Make sure you have the latest Chipset, Serial I.O and Management Engine Interface(MEI), Dynamic Platform & Thermal Framework (DPTF) and/or Intelligent Thermal Solution (ITS) drivers for your device:  

You can find and install the newest drivers from the Lenovo Support Page

Just plot in the serial number of the device and hit enter, might have to press it twice, then head to Drivers & Software then Chipset section.

**Note: Make sure the AC adapter is connected and that you have at least 30% battery charge when performing this update.

 

Regards

 

Voithos 



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Personal Message; questions belong in the forums.

Reply
Options

4 Posts

10-18-2020

GB

5 Signins

55 Page Views

  • Posts: 4
  • Registered: ‎10-18-2020
  • Location: GB
  • Views: 55
  • Message 3 of 4

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-19, 11:49 AM

Thank you for your comment. This behaviour is the same across Windows and Linux, with the exception of the "best battery life" mode in Windows I mentioned, which lowers the fan speed but is still problematic. So it doesn't relate to Linux. the problem exists on Windows.

 

I also have all updates installed via the Lenovo Vantage software/ Lenovo support website. I tried resetting the BIOS settings etc. The diagnostics also doen't repport any problem. The problem is there...

 

I wonder how many L14 users this problem affects, and how many already noticed it... (some may think that it is a loud fan at first...)

 

 

 

Reply
Options

4 Posts

10-18-2020

GB

5 Signins

55 Page Views

  • Posts: 4
  • Registered: ‎10-18-2020
  • Location: GB
  • Views: 55
  • Message 4 of 4

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-23, 8:40 AM

By the way this is a rough Linux script I wrote for my own Thinkpad (no warranties made) and personal use, until the BIOS and the fan auto mode is fixed. It could be a problem with my own unit, but for the moment I only have time to use my own script as a workaround.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete