Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

6 Posts

10-18-2020

United Kingdom of Great Britain and Northern Ireland

8 Signins

70 Page Views

  • Posts: 6
  • Registered: ‎10-18-2020
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 70
  • Message 1 of 11

L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-19, 5:20 AM

Hello, there seems to be a problem with my new L14 Thinkpad  (model 20U50001UK). The fan starts to spin at a certain temperature, then it spins faster when a threshold is reached, and faster, but never goes back to lower speeds. It is now noisy until I power off the machine and restart it (reboot doesn't solve the issue). 

 

It is probably not a hardware issue because:

  • The temperature sensors seem fine. It is only the fan speed deceleration that does not work. E.g. after a heavy load the fan continues to spin at high rate, even at 45 degrees C.
  • If I click on 'battery optimised' in the AMD power slider, it is the (only) way to get it temporarily back once it peaked to a higher speed. But this is not a workaround to me, because I want to use linux and also I want to use the full potential of the CPU.
  • I read similar threads of earlier Thinkpad models that had a similar issue fixed with a BIOS update. 

 

Shall I wait for a BIOS fix or return it? I really liked this thinkpad, but I am afraid if I get a replacement it will have the same issue, unless the BIOS is fixed as soon as possible... Does anyone else have the same issue or is it isolated?

 

Thanks

Reply
Options

2567 Posts

03-11-2020

Greece

275 Signins

12976 Page Views

  • Posts: 2567
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 12976
  • Message 2 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-19, 10:50 AM

Hello Philippos,

 

 

Does the fan operate the same when in the Windows environment ? If not, and they operate normally, then it's a good conclusion that this has to do with some un-compatible drivers in Linux. 

All one can do is wait for an update, or hope that some Linux guru finds a work around.

 

Meanwhile, you could make sure your system board is up to date:

 

Updating the Chipset and Thermal Solution Drivers  

Make sure you have the latest Chipset, Serial I.O and Management Engine Interface(MEI), Dynamic Platform & Thermal Framework (DPTF) and/or Intelligent Thermal Solution (ITS) drivers for your device:  

You can find and install the newest drivers from the Lenovo Support Page

Just plot in the serial number of the device and hit enter, might have to press it twice, then head to Drivers & Software then Chipset section.

**Note: Make sure the AC adapter is connected and that you have at least 30% battery charge when performing this update.

 

Regards

 

Voithos 



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

Reply
Options

6 Posts

10-18-2020

United Kingdom of Great Britain and Northern Ireland

8 Signins

70 Page Views

  • Posts: 6
  • Registered: ‎10-18-2020
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 70
  • Message 3 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-19, 11:49 AM

Thank you for your comment. This behaviour is the same across Windows and Linux, with the exception of the "best battery life" mode in Windows I mentioned, which lowers the fan speed but is still problematic. So it doesn't relate to Linux. the problem exists on Windows.

 

I also have all updates installed via the Lenovo Vantage software/ Lenovo support website. I tried resetting the BIOS settings etc. The diagnostics also doen't repport any problem. The problem is there...

 

I wonder how many L14 users this problem affects, and how many already noticed it... (some may think that it is a loud fan at first...)

 

 

 

Reply
Options

6 Posts

10-18-2020

United Kingdom of Great Britain and Northern Ireland

8 Signins

70 Page Views

  • Posts: 6
  • Registered: ‎10-18-2020
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 70
  • Message 4 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-10-23, 8:40 AM

By the way this is a rough Linux script I wrote for my own Thinkpad (no warranties made) and personal use, until the BIOS and the fan auto mode is fixed. It could be a problem with my own unit, but for the moment I only have time to use my own script as a workaround.

Reply
Options

2 Posts

12-06-2020

Germany

4 Signins

25 Page Views

  • Posts: 2
  • Registered: ‎12-06-2020
  • Location: Germany
  • Views: 25
  • Message 5 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2020-12-06, 23:20 PM

Hi,

just wanted to add that I'm facing the same issue, didn't try Windows though.

Also the fan is whining a lot on level 4.

 

Your script was helpful (but I think you should set both charge start & end (I use 70-80).

However your fan control is a bit too jerky and aggressive imo (I prefer it hot but silent, as long as it doesn't throttle).

I made some slight changes and consider writing a PID loop working towards a setpoint around 50°C:

 

minimum_fan_speed = 0 # an integer from 0 to 7

while True:
    # Read GPU and CPU temperatures and create a custom function for a value between 0-7
    tgpu = int(commands.getoutput("sensors|grep edge").split("+")[1].split(".")[0])
    tdie = int(commands.getoutput("sensors|grep Tdie").split("+")[1].split(".")[0])

    if (tgpu>65 and tdie > 75):
        current_fan_speed = current_fan_speed + 2
    elif (tgpu>65 or tdie > 75):
        current_fan_speed = current_fan_speed + 1
    elif (tgpu<55 and tdie < 60):
        current_fan_speed = current_fan_speed - 1
    elif (tgpu<50 and tdie < 55):
        current_fan_speed = current_fan_speed - 2

    current_fan_speed = min(7, max(minimum_fan_speed, current_fan_speed))
    print (tgpu, tdie, current_fan_speed)

    # Update fan level
    level = current_fan_speed
  os.)

    # Repeat every 6 seconds
    os.
Reply
Options

10 Posts

10-05-2020

Germany

10 Signins

60 Page Views

  • Posts: 10
  • Registered: ‎10-05-2020
  • Location: Germany
  • Views: 60
  • Message 6 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2021-02-10, 22:33 PM

I have the same problem with my Thinkpad L14 (BIOS 1.13). Once the fan has turned on it never turns off again. Even when the system is idle, the fan stays at:

 

% cat /proc/acpi/ibm/fan
status:        enabled
speed:        2978
level:        auto

 

I also don't have a good solution here except turning to some of the manual fan control options, which are pretty annoying.

Reply
Options

6 Posts

10-18-2020

United Kingdom of Great Britain and Northern Ireland

8 Signins

70 Page Views

  • Posts: 6
  • Registered: ‎10-18-2020
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 70
  • Message 7 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2021-02-11, 5:10 AM

Lenovo should definitely do something about this, as it also happens on Windows. On the other hand, I was happy with my script the last few months. In the meantime, I updated it to use more information, such as TDP, but is more customised and the fan curve may be different from laptop to laptop etc. Manually adjusting the fan is not "annoying" if you can customise it... It's the laptop's problem.

Reply
Options

10 Posts

10-05-2020

Germany

10 Signins

60 Page Views

  • Posts: 10
  • Registered: ‎10-05-2020
  • Location: Germany
  • Views: 60
  • Message 8 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2021-02-18, 19:45 PM
I meant no disrespect to your script. :) I agree that this seems to be a firmware problem of sorts and should be fixed by Lenovo.
Reply
Options

16 Posts

03-06-2021

Ukraine

9 Signins

95 Page Views

  • Posts: 16
  • Registered: ‎03-06-2021
  • Location: Ukraine
  • Views: 95
  • Message 9 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2021-03-06, 19:28 PM

The same issue on BIOS 1.16 - Windows 10 Pro. Also I notice that caller was stop only in sleep mode. Did someone have a working solution of this issue on Win platform?

Reply
Options

10 Posts

10-05-2020

Germany

10 Signins

60 Page Views

  • Posts: 10
  • Registered: ‎10-05-2020
  • Location: Germany
  • Views: 60
  • Message 10 of 11

Re:L14 AMD (BIOS 1.12) problem: fan only accelerates

2021-04-25, 13:42 PM
This issue is still present with BIOS 1.17.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All