Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

3 Posts

02-04-2021

Australia

4 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎02-04-2021
  • Location: Australia
  • Views: 15
  • Message 1 of 5

L580 Charges but doesn't run off AC

2021-02-04, 6:55 AM

Hi, My new L580 has just started freaking me out. I thought the charger wasn't working, because the little electricity icon didn't display when plugged in. But now I have noticed that my battery has climbed to 100%, but I am only running from the battery no AC power is used. I have tried updating all windows and lenovo software but no changes. Has anybody seen this before?

 

Regards,

 

David

Reply
Answer
Options

3 Posts

02-04-2021

Australia

4 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎02-04-2021
  • Location: Australia
  • Views: 15

Re:L580 Charges but doesn't run off AC

2021-02-05, 10:57 AM

Hi All - just wanted to say that I have resolved the issue by eventually finding the following post https://forums.lenovo.com/t5/ThinkPad-L-R-and-SL-series/L480-Unable-to-detect-AC-adapter-but-laptop-is-charging/m-p/4193554.

 

The solution was to hold down the power button for 20 seconds . . . no idea why that works but it did. I am very relieved!

 

Regards,

 

David

Reply

Replies(4)
Options

1265 Posts

01-08-2021

Philippines

86 Signins

6353 Page Views

  • Posts: 1265
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 6353
  • Message 2 of 5

Re:L580 Charges but doesn't run off AC

2021-02-04, 14:39 PM

Hello Davox,

 


Welcome to Lenovo Community

 

 

Make sure that the BIOS and drivers are up to date thru the support site.

Kindly follow the recommended steps here.

Update us how it goes

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

3 Posts

02-04-2021

Australia

4 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎02-04-2021
  • Location: Australia
  • Views: 15
  • Message 3 of 5

Re:L580 Charges but doesn't run off AC

2021-02-04, 21:16 PM

HI,

Thanks for your response.

 

I have done all update windows suggests.

I have also done all update Lenovo Vantage suggests, except for the following two updates -

 

ThinkPad BIOS Update - 10 [64] - 1.40

Intel Management Engine Firmware - 10 [64] - 11.8.80.3746

 

I have been unable to perform these updates because an error message insists that I connect the AC adapter (which is connected).

Note that I am fully charged at 100% thanks to the adapter, however it seems that the laptop is not detecting the adapter (despite allowing it to charge the battery).

 

Is there another way to perform these updates?

 

I seem to be stuck here . . .

 

Regards,

 

David

 

(Note that the situation is the same after turning the laptop off and allowing it to cool down overnight.)

Reply
Answer
Options

3 Posts

02-04-2021

Australia

4 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎02-04-2021
  • Location: Australia
  • Views: 15
  • Message 4 of 5

Re:L580 Charges but doesn't run off AC

2021-02-05, 10:57 AM

Hi All - just wanted to say that I have resolved the issue by eventually finding the following post https://forums.lenovo.com/t5/ThinkPad-L-R-and-SL-series/L480-Unable-to-detect-AC-adapter-but-laptop-is-charging/m-p/4193554.

 

The solution was to hold down the power button for 20 seconds . . . no idea why that works but it did. I am very relieved!

 

Regards,

 

David

0 person found this solution to be helpful.

This helped me too

Reply
Options

1265 Posts

01-08-2021

Philippines

86 Signins

6353 Page Views

  • Posts: 1265
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 6353
  • Message 5 of 5

Re:L580 Charges but doesn't run off AC

2021-02-12, 21:57 PM

Hello Davox,

 


That's great!
We're happy that you sort it out
If you encountered any issues, or if you have any questions, feel free to voice it out here on the forums

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms