English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

2 Posts

10-09-2012

Hong Kong

6 Signins

41 Page Views

  • Posts: 2
  • Registered: ‎10-09-2012
  • Location: Hong Kong
  • Views: 41
  • Message 1 of 3

Old timer : R40 restricted in UDMA2

2012-10-09, 4:23 AM

Recently I have this machine in extraordinary mint  conditon (the protective flim on the LED and model bezel still here!!), so i decided to give it an upgrade,

but seems it never recongnize any speed mode faster than UDMA2(both the HD and the ultrabay caddy), even the chipset clearly supports it (by using hdparm to force it working at UDMA5, rocketed from <30MB/s to >80MB/s in HDTune), plugging the drive at my T40 works like a charm, any ideas?

 

Here's what my R40 looks like

Type 2723-HB2

PM Banias 1.3GHz (tried to plug a Dothan 1.7GHz inside, but no-go)

Transcend 512M DDR333 x2

Sandisk P4 64G SSD with SATA->IDE adapter on HD slot, tried various 80-160G IDE HD, but still stuck at UDMA2

Sandisk Ultra 128G SSD with 3rd party ultrabay HD caddy, just a quick swap from my T40

 

they all restricted in UDMA2 mode which makes booting sloooooooow.... and no way to make the same trick in DOS....

 

Reply
Options

1 Posts

10-22-2012

Taiwan

1 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎10-22-2012
  • Location: Taiwan
  • Views: 6
  • Message 2 of 3

Re: Old timer : R40 restricted in UDMA2

2012-10-22, 9:41 AM

  IBM Thinkpad R40 did not detect the 80 pins cable using IDE's PDIAG(#32) by BIOS for UDMA transfer mode faster than 2 (<4,5,6) both in HDD 40 pins IDE connector or ultrabay's 80 pins connector, the only way to active it by "hdparm -X udma5" DOS command after hdparm S/W installation. However only the READ speed can be udma mode 5 but the WRITE speed still hold in udma mode 2.

  If PDIAG signal is LOW (ground), than the BIOS can verify HDD was connected via 80 pins cable and then support HDD to udma mode 4 or 5 or 6 (dependent on HDD device), the circuit diagram of R40 did not connect PDIAG pin to ICH4-M chip (shall be one of GPIO pin). Many old Notebook have same issued including HP, DELL, ASUS....etc.

  Please read the page-156 of Intel ICH4-M Platform Design Guide:

http://download.intel.com/design/intarch/designgd/27390305.pdf

  I'm still try to solve it by software including BIOS modification if possible.

Reply
Options

15 Posts

06-09-2014

UA

22 Signins

408 Page Views

  • Posts: 15
  • Registered: ‎06-09-2014
  • Location: UA
  • Views: 408
  • Message 3 of 3

Re:Old timer : R40 restricted in UDMA2

2021-01-08, 9:19 AM

Hi r40yoim825,

 

Did you have any luck with modifying the BIOS? I know it's an old post, but I have the same problem. I have done some research and it looks like the problem can only be solved by modifying the BIOS. I have tried to do something in that direction, but it is so difficult.

 

Would appreciate any reply from you.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms