English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

6 Posts

05-15-2008

Stellenbosch, South Africa

15 Signins

279 Page Views

  • Posts: 6
  • Registered: ‎05-15-2008
  • Location: Stellenbosch, South Africa
  • Views: 279
  • Message 1 of 4

R61: ethernet buggy

2008-05-19, 7:24 AM
I am using Debian Linux (Lenny) on my R61.   One of the more serious problems I have is that my network connection is not reliable. The network connection just seems to die and then I have to restart the network-manager or /etc/init.d/networking to get it working again for a few minutes.

I have tried several 2.6.24 and 2.6.25 kernels (vanilla, debian, ubuntu, suse, mandriva) and have the same problem with them all.  On the 2.6.24 kernels I am using the e1000 module and the 2.6.25 kernels e1000e. 

How do I determine whether it is a hardware problem or not?  Or maybe a bios problem?

Regards
Johann
Reply
Options

7651 Posts

11-24-2007

USA

5818 Signins

103093 Page Views

  • Posts: 7651
  • Registered: ‎11-24-2007
  • Location: USA
  • Views: 103093
  • Message 2 of 4

Re: R61: ethernet buggy

2008-05-19, 11:15 AM
Welcome to the forum!
 
When people have issues with their XP/Vista or whatever and can't clearly define whether it's a software or a hardware problem, I usually advise them to boot from a "live" Linux CD and see whether the issue persists...this time around I'm going to suggest the exact opposite: hopefully you've saved the recovery partition on your hard drive and can re-install Windows. Test out your LAN there, and you should be able to pretty clearly see whether the problem is software or hardware related.
 
Good luck and let us know.
Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
Reply
Options

6 Posts

05-15-2008

Stellenbosch, South Africa

15 Signins

279 Page Views

  • Posts: 6
  • Registered: ‎05-15-2008
  • Location: Stellenbosch, South Africa
  • Views: 279
  • Message 3 of 4

Re: R61: ethernet buggy

2008-05-19, 14:06 PM
The Recovery process ends with %s failed to restore your system. I did not touch the recovery partition and the Rescue and Recovery program becomes active when I boot from it.

Now I have no computer at all...
Reply
Options

6 Posts

05-15-2008

Stellenbosch, South Africa

15 Signins

279 Page Views

  • Posts: 6
  • Registered: ‎05-15-2008
  • Location: Stellenbosch, South Africa
  • Views: 279
  • Message 4 of 4

Re: R61: ethernet buggy (Solved)

2008-05-22, 8:12 AM
A new installation of Ubuntu so far seems to have solved the problem.  It is clearly not a kernel problem as I have tried the Ubuntu-kernel in Debian also. 

What also might have played a role is that I did a reset of the Bios to the factory default.  Maybe there was some funny bios setting previously.

Regards

Johann
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms