Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

1 Posts

04-20-2021

Czech Republic

1 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎04-20-2021
  • Location: Czech Republic
  • Views: 15
  • Message 1 of 2

Sound quality drop when 2 devices connected over internal BT

2021-04-20, 8:18 AM

Hello, i know.... multiple bluettoth connections are big toppic, but just to know if there is any possible option how to deal with my problem.

 

Setup:

 Lenovo ThinkPad L14 (Core I7, 16GB RAM....)

 First BT device -- Lenovo ThinkPad Bluetooth Silent Mouse (PN. 4Y50X88822)

 Second BT device -- heatphones Sony WH-H910N

 OP: Windows 10 Pro

 

The issue: 

When i have connected both devices mouse and heatphones (WH-H910N), the sound is sometimes stuttering. If i disconnect the mouse, sound is OK.

There is nothing like interfering between, if i connect the heatphones to my phone and mouse to the PC sound is ok. It has to be issue with bluetooth buffering in OP.

 

Any ideas how can i deal with it? Is it possible to prioritize bluetooth tasks to CPU? 

Yes, I have tried to reinstall my bluetooth drivers.

 

Thanks for your help

Michal

Reply
Options

2460 Posts

03-11-2020

Greece

266 Signins

12486 Page Views

  • Posts: 2460
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 12486
  • Message 2 of 2

Re:Sound quality drop when 2 devices connected over internal BT

2021-04-20, 8:41 AM

Hi misisnik,

 

Welcome to the Community Forums.

 

You can try setting the "bthserv" service in Task Manager - Details  to higher priority.

 

  1. Press Ctrl + Alt + Del and select the Task Manager.
  2. Head to the "Details" tab and try to find "bthserv"
  3. Right click it and select "Set Priority" , and choose anything higher then normal and test the quality again.

 

If it is not there, then try the following: 

 

Open up Command Prompt(Admin) and type the following command:

 

  • tasklist /svc /fi "imagename eq svhost.exe" 

 

You will see a list of process ID's. Find "bthserv" service and note down the corresponding PID (Process Identification/Identifier).

Go back to the details tab in Task Manager and find the PID you noted down (this should be the Bluetooth Service) and select a higher priority for it.

 

In the event this doesn't help solve the issue, you can check Windows store or google play store for apps that can help sett higher Bluetooth Connection priority. F.ex: Bluetooth Connection Priority Manager, and see if that works.

 

If you are able to set higher priority, but the quality is still not good, then this just boils down to the Bluetooth not having enough datastream for both devices to operate at a decent quality.

 

Best Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms