English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

4 Posts

02-09-2019

BG

6 Signins

62 Page Views

  • Posts: 4
  • Registered: ‎02-09-2019
  • Location: BG
  • Views: 62
  • Message 1 of 4

ThinkPad L390 (20NR) Black Screen on start when power cable is plugged

2020-04-25, 14:52 PM

When power up (or restart) the laptop won't start if the charging cable (USB Type-C) is plugged in.

Just stays with black screen and fans are working rapidly.

The laptop has only i7 built in graphics card, no external one.

 

Updated BIOS to latest 1.29 - does NOT fix the issue.

OS is Ubuntu 20.04 LTS.

 

I have tried 2 OEM chargers (power adapters) already - one from 2018 and one from 2019 - the issue is reproducible with both of them.

 

Lenovo ThinkPad L390 - serial number -********

Screenshot is attached.

 

Is this a driver, firmware or hardware issue?

When to expect a fix if any?

 

 

Moderator note: image containing serial number removed to prevent abuse. Corresponding MT-M is  20NR002DBM

Reply
Options

18 Posts

09-02-2018

DE

38 Signins

301 Page Views

  • Posts: 18
  • Registered: ‎09-02-2018
  • Location: DE
  • Views: 301
  • Message 2 of 4

ThinkPad L390 (20NR) Black Screen on start when power cable is plugged

2020-05-26, 11:49 AM
Same thing has been reported by many people with L380. For that, the BIOS upgrade caused the problem, and a rollback could be applied to fix it.
Reply
Options

4 Posts

02-09-2019

BG

6 Signins

62 Page Views

  • Posts: 4
  • Registered: ‎02-09-2019
  • Location: BG
  • Views: 62
  • Message 3 of 4

Re:ThinkPad L390 (20NR) Black Screen on start when power cable is plugged

2020-07-31, 13:12 PM

Problem is fixed with latest bios update 1.31

Thanks!

Reply
Options

18 Posts

09-02-2018

DE

38 Signins

301 Page Views

  • Posts: 18
  • Registered: ‎09-02-2018
  • Location: DE
  • Views: 301
  • Message 4 of 4

Re:ThinkPad L390 (20NR) Black Screen on start when power cable is plugged

2020-09-10, 21:17 PM
Thanks for letting me know. The BIOS upgrade also fixed it for me. However, it is pathetic that Lenovo took ~5 months to fix this.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete