Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics

7 Posts


cornwall ontario canada

16 Signins

41 Page Views

  • Posts: 7
  • Registered: ‎01-30-2011
  • Location: cornwall ontario canada
  • Views: 41
  • Message 1 of 2

bios update is causing problem to caps lock buttom

2011-01-30, 4:55 AM

hi i ma from ontario canada and i have lenovo sl500  80gb 1gb  vist home laptop

last week i updated my ram and my hard drive to 2gb /250gb and added windows 7 professional

formating from a dvd went smooth and everything worked perfactly

when i logeed i with my secure password which has a caps lock on and off and on while typing it, it worked with a caps lock led on and off and then on as usuall

i updated my whole windows 7 laptop with required security and hot fixes and i definitly know that caps lock had no trouble till i installed my lenovo thinkvantage update manager and update for required lenovo software like my finger print an all ..first it asked me to update bios --after i update it to new bios which was released recently kept my led for caps lock on for ever

now i am stuck with caps lock on for forever guys

do you know any twik /tune to fix it

most of my passwords are capslock related stuff

i can not use them like i used to use them before without looking at a screen corner where it says capls lock on

i mean why can not i use my caps lock key after updating bios ..why LED stays on all the time ?


please replay your answers to fix it ..or if you have similar issue on lenovo 2746-cto



Moderator note; e-mail address removed to stop the spambots getting it



1220 Posts


Perth, Australia

259 Signins

21576 Page Views

  • Posts: 1220
  • Registered: ‎12-24-2010
  • Location: Perth, Australia
  • Views: 21576
  • Message 2 of 2

Re: bios update is causing problem to caps lock buttom

2011-01-31, 10:30 AM

Hello mate,


Try to go in the BIOS and load default setup.

After that is trying to reinstall Hotkey.


Knowledge is of two kinds. We know a subject ourselves, or we know where we can find information on it.

ThinkPad T510 4313-CTO Windows 8 x64 - Intel Core i7-620M - NVIDIA NVS 3100M - 8GB RAM - 240GB SSD- Intel Centrino Ultimate-N 6300 - Gobi 2000.
ThinkPad Helix 3697-CTO Windows 8.1 x64 - Intel Core i7-3667U - Intel HD Graphics 4000 - 8GB RAM- 256GB SSD - Intel Centrino Advanced-N 6205 - Ericsson C5621gw

Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop





No, I don’t want to share ideas Yes, I agree to these terms