cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mracz
Fanfold Paper
Posts: 12
Registered: ‎01-06-2013
Location: AD
Views: 5,235
Message 1 of 4

Can not find fingerprint sensor device E7210005

Hi all,

 

I have Windows 7 x64 on my R61. I had to replace the fingerprint reader in my R61 palmrest as the old one was not functioning properly. The original reader unit has P/N 93P4393. I got a similar device with P/N 93P4378 and replaced the old one in the palmrest. I found  a driver at AuthenTec website, the installation was successful.  The new device shows in device manager under "Authentication Devices" as "TouchChip Fingerprint Coprocessor",  Driver date 26.08.2012, version 1.9.2.204, Hardware Id USB\VID_0483&PID2016&REV_0001.

 

So far fine. But if I download and install ThinkVantage Fingerprint Software it installs a different driver and there appears a yellow triangle with a an exclamation mark in the device manager, furthermore I can not enroll myself because of error E7210005 as the fingerprint sensor device is inaccessible. Removing the fingerprint software and installing AuthenTek Protector Suite 2012 fixes the driver issue (the yellow triangle disappears, the device seems to be properly installed in device manager) but the error prevails and I can not enroll. Device, driver & software seems to be installed properly but still the software can not find the fingerprint reader. "Can not find fingerprint sensor device" ERROR  E7210005

 

Any idea? Is this a hardware compatibility issue or a wrong driver/software? I tried all possible variations of existing drivers but could not have the device recognized by any fingerprint software.

 

Thanks for your comments.

Retired Support Specialist
Posts: 1,291
Registered: ‎12-06-2012
Location: Raleigh, NC
Views: 5,208
Message 2 of 4

Re: Can not find fingerprint sensor device E7210005

Hi, mracz

 

I did some research and was able to find this Lenovo thread that may be able to help you. Two users had this issue and posted possible fixes for you. One fix involves going into the settings of ThinkVantage Toolbox and having a component installed. The other possible fix occurs in Device Manager. I would make sure, however, that the Fingerprint Reader is being recognized by BIOS and is turned on. You can check this in Security > I/O Port Access.

 

Best of luck, and let me know how it goes,

Adam 

______________________________________________________________________________________________________________
Did someone help you today? Press the star on the left to thank them with a Kudo!

If you find a post helpful and it answers your question, please mark it as an "Accepted Solution!" This will help the rest of the community with similar issues identify the verified solution and benefit from it.
mracz
Fanfold Paper
Posts: 12
Registered: ‎01-06-2013
Location: AD
Views: 5,195
Message 3 of 4

Re: Can not find fingerprint sensor device E7210005

Thank you Adam

 

sorry

 

1. I can not locate Thinkvantage Toolbox anymore. This software seems to have been called back and replaced  by Lenovo some time ago.

2. There is nothing in BIOS under Security>I/O Port Acces on my R61 that would remind me to a fingerprint device. A couple of hardware items are located there, all of them installed properly in device driver, but no fingerprint device.

 

I tried all existing drivers of Authentec with no success. Better to say even if  the device driver is installed correctly, the Fingerprint Software does not find any fingerprint device. Furthermore I realized, that the faulty device had a black colour connector and this one I placed in the palmrest has a white connector. I tend to the proud conclusion that this is rather a hardware compatibility issue  than my factual incompetency for selecting and installing a proper driver in Windows.

 

Anyway thank you for bothering me.

mracz
Fanfold Paper
Posts: 12
Registered: ‎01-06-2013
Location: AD
Views: 5,107
Message 4 of 4

Re: Can not find fingerprint sensor device E7210005

Problem solved.

 

I recently upgraded to W8 and after installation the new fingerprint reader was recognized and installed properly. it seems, that the fingerprint reader device can not be replaced without reinstalling windows. I do not know the reason. In Vista there was a software yet to switch the availability of the security chip which apparently made possible to replace the fingerprint device without reinstallation of the full op system from scratch. In W7 I think it is not possible anymore. If you replace the biometric device you need to reinstall windows to have it working again as usual.

 

Btw upgrading W7 to W8 did not work with me (at the time it did not work from XP to Vista, from Vista to W7 either, maybe I am the unlucky boy). BSOD. Don't bother upgrading, a good backup and installation from scratch will do the job.

Check out current deals!


Shop current deals

Top Kudoed Authors