English Community

ThinkPad NotebooksThinkPad: L, R and SL series Laptops
All Forum Topics
Options

3 Posts

01-18-2009

Brunico (BZ), Italy

6 Signins

57 Page Views

  • Posts: 3
  • Registered: ‎01-18-2009
  • Location: Brunico (BZ), Italy
  • Views: 57
  • Message 1 of 9

Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-01-18, 18:39 PM

Hello,

 

my R51 (2887-32G) randomly drops wireless connection, especially when starting to download large files. For instance, when I try to download iTunesSetup.exe, the download is interrupted. Instead, if I just surf webpages, the problem occurs less.

I tried a Live Distro (xubuntu) and this problem does not occur there.

 

The problem manifests with Windows XP (with all latest updates and sp), using the 1.2.4.41. There used to be more recent drivers on intel's website, but I saw that they've removed them.

 

I remember using this laptop 3 years ago with and wireless was OK - no trouble at all. And I do remember I was using the intel driver. Unfortuantely, I have no backup of this driver and upgraded my R51 in the meantime, so I am with the default drivers again. Or maybe SP3 might be the problem?

 

Thanks for any advice!

 

Message Edited by pi4630 on 01-29-2009 10:57 PM
Reply
Options

10 Posts

01-27-2009

Ontario Canada

21 Signins

134 Page Views

  • Posts: 10
  • Registered: ‎01-27-2009
  • Location: Ontario Canada
  • Views: 134
  • Message 2 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-01-30, 4:56 AM

I am having the EXACT same problem on a T41 with the same card.

 

There is a thread in that forum for it.

 

I even tested doing the same as yourself with 8.0.4 Xubuntu.. no problems.

 

I think this is an SP3 issue.

 

I also see that Intel has issued an EOS on this card.. so I would assume we are not going to see anymore updates that would help us out.

 

Please if you do find a solution, post it. I think an upgrade of wireless card if you want to continue to use SP3 will have to be the choice.

 

James

Reply
Options

3 Posts

01-18-2009

Brunico (BZ), Italy

6 Signins

57 Page Views

  • Posts: 3
  • Registered: ‎01-18-2009
  • Location: Brunico (BZ), Italy
  • Views: 57
  • Message 3 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-01-30, 7:06 AM

I've purchased the Intel PRO/Wireless 2200BG Mini-PCI Adapter, but I didn't mount it yet.

I agree with you that this must be an SP3 issue, because the card used to work correctly years ago - when the OS had just SP1 / SP2 installed (it makes me laugh "it's not a bug, it's a feature!" ;) )

I found the "latest" Intel driver for that card, but it doesn't fix the problem. As soon as I've mounted that card, I will report back again here.

However, have a look at ThinkWiki, it seems that your model does not come with the 2200BG and I read here somewhere in the forum that IBM shipped his ThinkPads with "Whitelists" for Mini-PCI cards. It could be that, if you'd mount this 2200BG, your ThinkPad would stop at the bios and prompt you to remove the card.

Message Edited by pi4630 on 01-29-2009 11:07 PM
Reply
Options

4 Posts

02-10-2009

USA

10 Signins

54 Page Views

  • Posts: 4
  • Registered: ‎02-10-2009
  • Location: USA
  • Views: 54
  • Message 4 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-02-10, 18:30 PM
I never had trouble with my card (use a T40 laptop) until I switched routers and tried to use WPA. I understand the 2100 supports WPA and I could see the network but not connect ... now after I disabled the wireless card I can't re-enable it.  About to uninstall and reinstall driver software. Anyone seen this before? Any advice on router/wireless/XP settings to enable the 2100 to connect to a WPA/WPA2 network? I'm using an Airport Extreme. My OS on the T40 is XP SP3.
Reply
Options

3 Posts

01-18-2009

Brunico (BZ), Italy

6 Signins

57 Page Views

  • Posts: 3
  • Registered: ‎01-18-2009
  • Location: Brunico (BZ), Italy
  • Views: 57
  • Message 5 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-02-10, 18:43 PM

hb80, try to uninstall SP3 before using WPA. Test if it works with just the ServicePack2 installed. It solved the problem on a Mac running Windows (I've posted this solution also in an Apple forum).

The 2100 supports WPA but the combination 2100 + SP3  won't. Try it yourself, start any recent Linux live CD with WPA/WPA2 on your router enabled and the connection will not drop!

 

If you want to keep SP3, you must switch to use WEP (which is less secure), so choose your tradeoff. ;)

Message Edited by pi4630 on 02-10-2009 10:45 AM
Reply
Options

1 Posts

04-07-2009

WI, USA

4 Signins

16 Page Views

  • Posts: 1
  • Registered: ‎04-07-2009
  • Location: WI, USA
  • Views: 16
  • Message 6 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-04-07, 0:44 AM
Same problem here, on a client's machine (WinXP SP3 Home).  I'v found that using the Intel PROset to control the wireless connection improves the fault-tolerance of the dropped connections; that is, although the connection still drops with some frequency, programs are less likely to see that this has occured than they are with the windows connection management.
Reply
Options

2 Posts

04-09-2009

US

5 Signins

69 Page Views

  • Posts: 2
  • Registered: ‎04-09-2009
  • Location: US
  • Views: 69
  • Message 7 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-04-09, 19:10 PM

I have the same connection problem.

 

I've been using a T41 with a 2100 3b for years now. Two days ago the connection started dropping not only on my home network (which worked fine before) but also on other networks every couple of seconds. I formatted the hard drive and reinstalled XP and the latest drivers for the card.

 

The problem still persists... Also, I am still on SP2 and I have not yet installed SP3.

 

 

Reply
Options

10 Posts

04-03-2008

Calgary, Alberta, Canada

40 Signins

814 Page Views

  • Posts: 10
  • Registered: ‎04-03-2008
  • Location: Calgary, Alberta, Canada
  • Views: 814
  • Message 8 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2009-11-13, 5:34 AM

Did anyone figure out a solution to this problem?

 

I'm now having the same issue. I have an X31 that worked perfectly on my wireless router. I think installed Linux Mint and it works fine and can hold a connection for days at a time.

 

I recently installed a fresh version of Windows XP SP2 from an install disk, and my Intel 3100 3b can't hold a connection for more than a few minutes. If I start downloading a large file, it drops the connection immediately.

 

In the mean time, I have 2 other laptops that are holding a connection to this router without any issues.

 

Any thoughts on how to fix this?

 

Thanks

James

Reply
Options

1 Posts

10-24-2017

US

11 Signins

44 Page Views

  • Posts: 1
  • Registered: ‎10-24-2017
  • Location: US
  • Views: 44
  • Message 9 of 9

Re: Intel PRO/Wireless 2100 3b Mini PCI adapter drops connection

2017-10-24, 2:54 AM

I had the same dropping signal problem on HP TC1100 with same adapter Intel Pro Wireless 2100. WinXP SP3 and WPA security. I solved the problem by uninstalling intel PROSET software which controls the adapter settings and power management. And I checked the option wireless settings for Windows to control the wireless connections. After that I made a new connection to the router with WPA security - and I dont see any problems with dropping signal or connection anymore. Hope this helps.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete