cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ludo-Levono
Paper Tape
Posts: 2
Registered: ‎03-25-2019
Location: ES
Views: 1,386
Message 1 of 3

L380 won't boot up after enabling Legacy Only

Hi,

 

I have this laptop for work use. Due my work, I need to boot on Linux from time to time, and I use a Live USB with it. In order to be able to boot with that Linux Live USB i followed the following steps:

 

1.- Press Shift and Reboot

2.- Select Troubleshooot>advanced options>UEFI Firmware Settings and reboot

3.- On security tab > disable securite boot

4.- On Startup tab > UEFI/Legacy Boot --> select Legacy only

 

After doing that I was able to boot with my Linux Live USB and work normally, but when I shutdown the laptop, remove the usb, boot the laptop again and set back to defaults on the BIOS, the laptop wont boot up.

 

I re-enable the secure boot on security tab, and selected UEFI on the UEFI/Legacy boot on startup tab, but the laptop is not booting.

 

Please help

Ludo-Levono
Paper Tape
Posts: 2
Registered: ‎03-25-2019
Location: ES
Views: 1,360
Message 2 of 3

Re: L380 won't boot up after enabling Legacy Only

Hi!

 

I´ve finally fixed the issue. 

 

As I said before, sefting the Bios to default (F9) was not leting me boot back from windows. Extrangely after setting the bios back to default and saving, the laptop just went back to the boot process and got stuck unable to boot. When I checked the BIOS in the security tab>secure boot was disabled, and also the UEFI/Legacy Boot on the startup tab was again on Legacy (even though I set it back to UEFI)!!

 

The solution was: On another compluter create a bootable Windows 10 USB, boot the laptop with it, then reboot it and set the BIOS as follows:

security tab>Secure boot --> ENABLED

startup>UEFI/Legacy Boot --> UEFI Only

restart>Load Setup Defaults -- OS Optimized Defaults (DISABLED)

save, restart and remove bootable Win 10 USB

 

After doing that, the system booted up on windows. Then I rebooted again, pressed enter to go to the menu, pressed the key to go to the BIOS and in restart>Load Setup Defaults -- OS Optimized Defaults (ENABLED) enabled again the OS Optimized defaults.

 

I hope it helps others in the same situation.

 

Regards

 

 

kharis
Paper Tape
Posts: 1
Registered: ‎09-09-2019
Location: ID
Views: 726
Message 3 of 3

Re: L380 won't boot up after enabling Legacy Only

Hi!

Thanks for sharing this solutions, you save my day there. So is this a BIOS bug? or something else?


Regards

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors