cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
protik77
Ctrl-Alt-Del
Posts: 6
Registered: ‎07-30-2015
Location: US
Views: 359
Message 1 of 5

L440 "configuration changed - Restart the system" at boot screen

Hi all,

 

I have a L440 Thinkpad. About 3 years back I pulled out the HDD, put in a SSD. Replaced the optical drive with a HDD caddy. The combination worked really great so far.

 

Recently I replaced my aging SSD with a new one. Basically I cloned the old SSD to a new one. Now after the reboot, the boot screen shows the message, "configuration changed - Restart the system". It is connected to the HDD caddy. If I remove the caddy, the system boots up fine. But whenever I insert the caddy, the system does not boot anymore. I can't even get to the boot menu. It get's stuck in a boot loop.

 

So I am trying to understand why this is happening here. Other than a new SSD, the caddy is same all the way. It worked before, so no apparent reason for it to stop working. Unless the BIOS firmware is manually checking for allowed FRU after detecting hardware change. Has anyone faced this problem?

 

Any help or pointers regarding this is greatly appreciated. Thanks.

Social Support Agent
Social Support Agent
Posts: 288
Registered: ‎08-01-2018
Location: PH
Views: 243
Message 2 of 5

Re: L440 "configuration changed - Restart the system" at boot screen

Hi protik77!

 

Welcome to the community forums.

 

Yes, we do have a white list of the parts of every Lenovo computers may be that's why the laptop don't recognize the upgraded parts anymore. You can check this https://download.lenovo.com/parts/ThinkPad/l440_fru_list_20140825.pdf?CID=ww:lenovosocial:20x9m6 for the list of recommended and tested parts for your Thinkpad L440.

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

heroe
Paper Tape
Posts: 3
Registered: ‎03-05-2019
Location: SK
Views: 92
Message 3 of 5

Re: L440 "configuration changed - Restart the system" at boot screen

Ok so you are telling us that we can´t use our HDDs any more? Here is another thread abou this issue https://forums.lenovo.com/t5/ThinkPad-L-R-and-SL-series/Lenovo-L440-problem-with-HDD-caddy/m-p/33552... is there any workaround?

Community SeniorMod
Community SeniorMod
Posts: 8,950
Registered: ‎01-01-2010
Location: US
Views: 40
Message 4 of 5

Re: L440 "configuration changed - Restart the system" at boot screen

There is no whitelist for disks.  My guess is that the cloning process did not copy partition structure quite correctly and that when you began booting from tho optical, the windows boot manager was on the other drive.


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
heroe
Paper Tape
Posts: 3
Registered: ‎03-05-2019
Location: SK
Views: 32
Message 5 of 5

Re: L440 "configuration changed - Restart the system" at boot screen

There are hdd´s in that fru list... As i posted, there are more people encountering this problem.... I have just added new hdd in optical drive caddy it worked well. Restart loop started after bios update. Only workaround that worked, was to swap system ssd and data hdd. Now i have ssd in optical caddy and hdd in original hdd mounting place an pc is working well. But that is not a solution.

Check out current deals!


Shop current deals

Top Kudoed Authors