cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Audijo
Paper Tape
Posts: 1
Registered: ‎11-17-2014
Location: Germany, Bochum
Views: 1,553
Message 1 of 8

L540 HDD in Ultrabay not recognised in BIOS

Hello everyone.

 

I have recently got a new ThinkPad L540. Since I need to use Windows 7 (TrueCrypted company Installation on normal SSD) and Ubuntu I bought a HDD Caddy for the UltraBay together with a 1TB HDD.

 

My problem is, that I can not select the second HDD (HDD1) in the BIOS to boot from. It does not show the name of the drive, just HDD1. HDD0 has a name that indicates that it is the Intel SSD. The new drive is visible and usable in Windows and when I use a USB-Drive to install Linux on that second Drive.

Furthermore I switched the SSD and the HDD and the L540 boots sraight up into Ubuntu. When I switch back its boots Windows 7 again. 

During the Ubuntu installation I tried both, writing the GRUB2 bootloader to the root-partition or to the beginning of the HDD (schould be the same since the root-partition is the first on the drive). Gparted is also thelling me that the root-partition is bootable.

 

I hope somebody has an idea!

Thank you very much for your help in advance!!!

 

kamil4772
Paper Tape
Posts: 3
Registered: ‎12-18-2014
Location: Poland
Views: 1,434
Message 2 of 8

Re: L540 HDD in Ultrabay not recognised in BIOS

I have exactly the same problem . Bad solution is to change the AHCI to IDE mode in BIOS. Do you have an idea how to solve it?
yoda73
What's DOS?
Posts: 2
Registered: ‎06-27-2015
Location: Siegen
Views: 1,215
Message 3 of 8

Re: L540 HDD in Ultrabay not recognised in BIOS

Hi,

 

I have the same problem, too !

 

Any solution ?

 

Greets

Guru
Posts: 1,412
Registered: ‎06-08-2013
Location: BE
Views: 1,192
Message 4 of 8

Re: L540 HDD in Ultrabay not recognised in BIOS

  1. Which product are you using for the ultrabay HDD module?
  2. What BIOS version are you on? 

Warm regards,
Jonas Hendrickx

Lenovo Insider - Windows Insider MVP

Personal website: ThinkScopes

yoda73
What's DOS?
Posts: 2
Registered: ‎06-27-2015
Location: Siegen
Views: 1,185
Message 5 of 8

Re: L540 HDD in Ultrabay not recognised in BIOS

Guru
Posts: 1,412
Registered: ‎06-08-2013
Location: BE
Views: 1,173
Message 6 of 8

Re: L540 HDD in Ultrabay not recognised in BIOS

Have you also contacted the seller to get a different one?

Warm regards,
Jonas Hendrickx

Lenovo Insider - Windows Insider MVP

Personal website: ThinkScopes

Liingon
Paper Tape
Posts: 1
Registered: ‎12-11-2015
Location: Sweden
Views: 987
Message 7 of 8

Re: L540 HDD in Ultrabay not recognised in BIOS

I too have the same problem, has anyone been able to find a solution?

trisomeyr
What's DOS?
Posts: 1
Registered: ‎03-23-2016
Location: DE
Views: 670
Message 8 of 8

Re: L540 HDD in Ultrabay not recognised in BIOS

I also have got this Problem. The Drive is recognized in the Diagnostics Screen on startup. It is also recognized in Win 10 Setup. But if you try to install the os it says, that windows maybe cannot boot from this drive and the setup dosnt continue. BIOS is up-to-date.

 

Any Solutions?

Check out current deals!


Shop current deals

Top Kudoed Authors