cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
srkinney
What's DOS?
Posts: 1
Registered: ‎01-04-2010
Location: Montana
Views: 1,993
Message 1 of 5

Missing device drivers

Had to reinstall Win7 Pro OS over Home Premium for school environment. Now laptop says that it needs three device drivers for "base system device"...what is this driver called and where can I find it to download and install?

 

Thanks!

 

sk

GregWms
Paper Tape
Posts: 1
Registered: ‎01-05-2010
Location: US-Ca.
Views: 1,949
Message 2 of 5

Re: Missing device drivers

Greetings - 1st Post

Thanks for reading.

 

SL500 2746-CTO; Clean install of Win7 on blank drive.

 

I also have two devices in the intel 82801 pci bridge 2448

"base system device"

 

I also have problems with hotkeys either not working, not working properly (doesn't work with headphones plugged in), or other function keys.  Used latest drivers.

 

 

Best regards,

Greg

Retired Moderator
Retired Moderator
Posts: 3,220
Registered: ‎07-31-2008
Location: Pakistan
Views: 1,813
Message 3 of 5

Re: Missing device drivers

Welcome to the forum guys!


For Base System device, check this thread:- http://forums.lenovo.com/t5/SL-Series-ThinkPad-Laptops/Base-System-Device-Driver/td-p/178788


Hope it helps.
------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Lenovo Staff
Lenovo Staff
Posts: 807
Registered: ‎01-16-2010
Location: US
Views: 1,789
Message 4 of 5

Re: Missing device drivers

For the hotkeys, use the package from this site:

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-74261

 

Seems to be newer than the one listed in the driver matix.  All my hotkeys work fine on Win7 now.

CBR900RR
Fanfold Paper
Posts: 1
Registered: ‎05-20-2009
Location: Hawaii/USA
Views: 1,765
Message 5 of 5

Re: Missing device drivers

I need to install these for the HOTKEY to work

 

Hotkey Features Integration for Windows 7, Vista, XP and 2000 - ThinkPad   2009-12-21 
ATK Hotkey driver for Windows 7 - ThinkPad SL300, SL400, SL400c, SL500, SL500c   2009-10-02 
Lenovo System Interface Driver for Windows7, Vista and XP - Notebooks   2009-08-31 

 

 

For the "base system device", I have to  use the beta windows 7 "card driver"

 

http://www-307.ibm.com/pc/support/site.wss/WIN7-BETA.html#rmcr

Ricoh Multi card reader win 7-7kss55ww

 

I also install these driver

 

ThinkVantage Active Protection System for Windows 7 (64-bit), Vista (64-bit) - ThinkPad   2009-12-17 


ThinkVantage System Update 4.0   2009-10-19

 

My system is a very basic SL500, no webcam, fingerprint scan, just the basic 2gb ram, 160gb HD, T6570 cpu, intergrate sound and video, running windows 7 64bit, and device manager is all clear, no exclamation mark.

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors