Support in other languages: 
Showing results for 
Search instead for 
Do you mean 

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team

Community Spotlight

Visit the Community Blog

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Reply
Fanfold Paper
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0 Kudos
Accepted Solution

""Unknown PCI Device " ????

[ Edited ]

Hello everyone, just had a Z61T bought for me as a replacement for a busted ACER, and I have to be honest and say I'm seriously pleased with it Smiley Happy

BUT, I have a problem, a niggle as it were. Everytime I boot up and get va little message in the task bar telling me that "new hardware" has been found, as above, initially the wizard describes it as IDE ATA/ ATAPI controller, then disappears when I cancell it and it returns as " Unknown PCI Device". I can't find any drivers, none are installed, can't roll back can't even uninstall whatever it might be. Device Manager is no help at all- so any and all ideas greatly appreciated and welcome !!

 

I do love this machine tho Smiley Happy

 

EDIT :  Sorry forgot to say I'm running XP Pro SP3 2GHZ model( T72000) and 2GB RAM

Posts: 2,917
Topics: 106
Kudos: 158
Blog Posts: 0
Solutions: 123
Registered: ‎02-22-2008
Location: US
0 Kudos

Re: ""Unknown PCI Device " ????

Install system update,it should fetch the required drivers

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-66956




Cheers and regards,
• » νιנαソѕαяα∂нι ѕαмανє∂αм ™ « •
●๋•کáŕádhí'ک díáŕý ツ


I am a volunteer here. I don't work for Lenovo
Fanfold Paper
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0 Kudos

Re: ""Unknown PCI Device " ????

[ Edited ]

I agree it should but it doesn't, I have attempted that 2x now and still no progress Smiley Sad

further info:-

PCI bus 0, device31, function 2  ?????

PCI device properties under device manger  only reveals under "details" -

PCI\VEN_8086&DEV_27C5&SUBSYS_200D17AA&REV_02\3&B1BFB68&0&FA

No drivers, no rollback available , nothing!

 

It shows up as a windows  storage device when I run AIDA32 ??

 

Any ideas to what it is exactly ? At least it'd give me a chance of tracking down a driver and getting rid of this irritating message and window

Posts: 7,626
Kudos: 759
Solutions: 802
Registered: ‎11-23-2007
Location: USA

Re: ""Unknown PCI Device " ????

Install the Intel chipset driver to begin with.


http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-62939


Your missing device is likely to be a card reader.


http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-67470


Good luck.

Cheers,

George




In daily use: R60F, R500F, T61, T410

Collecting dust: T60

Enjoying retirement: A31p, T42p,

Non-ThinkPads: Panasonic CF-31 & CF-52, HP 8760W




Starting Thursday, 08/14/2014 I'll be away from the forums until further notice. Please do NOT send private messages since I won't be able to read them. Thank you.
.
Fanfold Paper
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0 Kudos

Re: ""Unknown PCI Device " ????

I'll try that ,many thanks , I'll get back and lte you know Smiley Happy

Highlighted
Fanfold Paper
Posts: 19
Registered: ‎03-09-2011
Location: United Kingdom
0 Kudos

Re: ""Unknown PCI Device " ????

hey hey hey ! guess who's got a sn

miley face ??

First off thanks for all the input /suggestions, it wasn't any of the above but certainly in the ball-park, it was in fact an update to the Intel Storage Manager driver that was required but hey I wouldn't have known to look at it if it wasn't for your suggestions .

 

So, BIG THANK YOU !!

Karlo