Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad P and W Series Mobile Workstations Knowledge Base

P52 4K, reboot three times forever, after Update Intel ME Management Engine 12.0 Firmware


When cold booting the computer the keyboard lights up, power button lights up, fans spin up, screen stays blank, this goes on for 1 - 2 seconds, then it completely turns itself off. And then repeat. After the third time it actually does not turn off, but rather the boot logo appears.




 These steps also work for P52, P72 and P1/X1 Extreme.  Here are the steps:


1.  Plug in AC power

2.  Reboot the system (we want to start from a freshly-booted state)

3.  Save this file to your PC:  RecoverDisabledPlatform_12.0.35.1427_v2.zip

4.  Unzip the file to some folder on your PC

5.  From the unzipped folder, right-click on SleepResumeUpdateFW_Reset.cmd and choose Run as Administrator

6.  If you see a screen like "Windows protected your PC", you may need to click on More info and and then click on Run anyway.

7.  If you see a screen like "Do you want to allow this app to make changes to your device", click on Yes.

8.  The system will go to sleep for 30 seconds, and then wake up automatically.  Please do not try to wake it up manually.  Just wait.

9.  After the system wakes up, you should see the firmware flashing to the new version, it may take a couple minutes, please don't interrupt it.

10.  The system will reboot automatically, after this, the problem should be gone

11.  To confirm the new firmware updated successfully, reboot and press F1 to enter BIOS Setup, then look for "ME Firmware Version"


Was this information helpful?

Yes No


tekyman007 On 2019-05-08, 19:03 PM

But this will not work for a P52 whose motherboard has already been changed. Plese confirme.

newtonx On 2019-05-30, 5:17 AM

Hi! I followed the steps restart or shut down-start and run the SleepResumeUpdateFW_Reset as admin, but the installation just flashed and then nothing happened.

I also tried downloading the "ME Firmware Version" to install. Again, the intallation flashed and nothing happened. When I used Vantage, it just said "failed to update".


EDIT: It worked! but for some reason I got black screen upon startup and had to restore to previous restore point

fldevs On 2019-06-03, 13:55 PM

The link in this post is dead....please advise

Arnold_Pxx On 2020-01-18, 9:15 AM

This solution works great for my P52, thanks! 1x booting is enaugh.

By the way, this 3x times reboot-thing occured after change of motherboard due to a bios-brick.

Boot-time is now "OK", but it could be much more faster.

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop