Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

5 Posts

03-20-2021

Ireland

6 Signins

15 Page Views

  • Posts: 5
  • Registered: ‎03-20-2021
  • Location: Ireland
  • Views: 15
  • Message 1 of 4

2560x1440 missing after bios 1.26

2021-03-20, 14:22 PM

Hi all,

since I updated my bios from original 1.14 to 1.26, executed on Windows, res 2560x1440 is missing. I used it primarely and is still is available on Linux. Since downgrade isn't possible, I'm stuck here. Neither Win nor Intel settings allow 2k. A bunch of other 2560s, 4k, full hd and so on are available though.

 

Support seems to be clueless and suggests to wait for further updates ... anyway, has anyone suggestions? Here some details

 

ThinkPad 73
LCD IPS 17.3 on Intel UHD 630 & RTX 3000
Windows 10 Pro
Version 20H2 - 19042.685
Experience Pack 120.2212.551.0

 

The issue can be replicated on older Win10 versions too. It's been a few weeks now since my TS but this issue is fixable somehow.

 

Any suggestions? I dislike down scaling 4k :(

 

Cheers,

Victor

 

Reply
Options

2074 Posts

01-08-2021

Philippines

142 Signins

10535 Page Views

  • Posts: 2074
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 10535
  • Message 2 of 4

Re:2560x1440 missing after bios 1.26

2021-03-22, 12:27 PM

Hello vjouhoff,

 


Welcome to Lenovo Community

 


I suggest that you share the machine type model / MTM (ex. 81C70000RK) from the sticker as it would help us detail more about your machine variant.

Try load BIOS default settings then save before exiting

 Update us soon as convenient

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

5 Posts

03-20-2021

Ireland

6 Signins

15 Page Views

  • Posts: 5
  • Registered: ‎03-20-2021
  • Location: Ireland
  • Views: 15
  • Message 3 of 4

Re:2560x1440 missing after bios 1.26

2021-04-02, 16:25 PM

Hi, the number is 20QR-CT01WW. I tried default settings including secure boot on and off without any change. Thanks for your help!Victor

Reply
Options

2074 Posts

01-08-2021

Philippines

142 Signins

10535 Page Views

  • Posts: 2074
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 10535
  • Message 4 of 4

Re:2560x1440 missing after bios 1.26

2021-04-14, 20:02 PM

Sorry for the late reply.

 

I will send a private message wherein you can reply containing serial number of the machine, since the computer appears as CTO (Customized to Order). 

Meanwhile try to check if the display driver version is the same as from the support site.

If not, uninstall and remove the existing driver from the device manager, be sure to completely delete it from the system.

Then download and install the ones from the support site. 

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms