Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

25 Posts

11-05-2008

Dublin, Ireland

62 Signins

414 Page Views

  • Posts: 25
  • Registered: ‎11-05-2008
  • Location: Dublin, Ireland
  • Views: 414
  • Message 1 of 5

BAD_POOL_CALLER BSOD on resumer from Standby / Hibernation

2009-01-30, 12:14 PM

I've got a W500 and am running Windows Vista Ultimate, SP1.

 

Background: I was using the switchable graphics, with the most up to date driver from Lenovo for the BIOS and the graphics cards.  I was also one of the unlucky ones who experienced random driver sessation and crashing while using the machine and also random inactivity on resumes from Standby mode.

 

I then went through the instructions to use the AMD driver on the AMD graphics card only, by shutting off the other card, disallowing switchable graphics in BIOS and modding the newest driver from AMD as detailed in the other thread.  Now, however, any time I suspend and try to resume the laptop, be it from Standby or Hibernation mode, I get a Bluescreen, with the message at the top "BAD_POOL_CALLER".  I get this every single time, no matter what I do or try.

 

This W500 is easily the most powerful laptop that I've ever used, without a doubt, it blows most desktops that I've used in my life out of the waters they were in, but it unfortunately now, the most troublesome and unreliable laptop I've ever used.  I've had huge problems with the Fingerprint reader, with the Security Manager and constant problems with the graphics.  I'm using this for hours, daily and having to constantly shutdown and startup from a cold boot is really starting to get to me.

 

Can someone please try and help, I can dig for any more information that you need to try and get to the root of this.

Reply
Answer
Options

25 Posts

11-05-2008

Dublin, Ireland

62 Signins

414 Page Views

  • Posts: 25
  • Registered: ‎11-05-2008
  • Location: Dublin, Ireland
  • Views: 414

Re: BAD_POOL_CALLER BSOD on resumer from Standby / Hibernation

2009-02-02, 3:53 AM
I posted my details on the techguy forums and one of the members identified my Comodo Firewall as one of the root causes for the bluescreens.  I've since uninstalled and no I can Sleep and resume to my hearts' desire.  I've posted what happened on the Comodo forums too, so hopefully they'll be able to find a full solution.
Reply

Replies(4)
Options

25 Posts

11-05-2008

Dublin, Ireland

62 Signins

414 Page Views

  • Posts: 25
  • Registered: ‎11-05-2008
  • Location: Dublin, Ireland
  • Views: 414
  • Message 2 of 5

Re: BAD_POOL_CALLER BSOD on resumer from Standby / Hibernation

2009-02-01, 15:24 PM
Hi, I'm just wondering if there's anyone here who can assist me, I think these dodgy Bluescreen's are adversely affecting the performance of the machine.
Reply
Options

147 Posts

11-13-2008

Scotland

163 Signins

2737 Page Views

  • Posts: 147
  • Registered: ‎11-13-2008
  • Location: Scotland
  • Views: 2737
  • Message 3 of 5

Re: BAD_POOL_CALLER BSOD on resumer from Standby / Hibernation

2009-02-01, 18:44 PM

Ok here a checklist for you.

 

Are you using the preload? 

Has it happened before (out of the box?)

Have you deinstalled all updates and drivers and checked if the problem occurs then?

What exactly is the stop mcode if you get any apart from the bad pool caller.

 

Check out http://support.microsoft.com and have a look at the knowledgebase. Have you installed any other software or even the real driver for the graphics card?

 

What BIOS do you use? Have you installed any hardware lately? Do you get this error in safe mode?

 

Cheers

Message Edited by crisdean on 02-01-2009 06:44 PM
Reply
Options

25 Posts

11-05-2008

Dublin, Ireland

62 Signins

414 Page Views

  • Posts: 25
  • Registered: ‎11-05-2008
  • Location: Dublin, Ireland
  • Views: 414
  • Message 4 of 5

Re: BAD_POOL_CALLER BSOD on resumer from Standby / Hibernation

2009-02-02, 0:36 AM

wrote:

Ok here a checklist for you.

 

Are you using the preload? 

Has it happened before (out of the box?)

Have you deinstalled all updates and drivers and checked if the problem occurs then?

What exactly is the stop mcode if you get any apart from the bad pool caller.

 

Check out http://support.microsoft.com and have a look at the knowledgebase. Have you installed any other software or even the real driver for the graphics card?

 

What BIOS do you use? Have you installed any hardware lately? Do you get this error in safe mode?

 

Cheers

Message Edited by crisdean on 02-01-2009 06:44 PM

 

1. preload, as in the original install that came on the laptop? yes, I am.

2. this exact error, no it did not happen out of the box, but I did get the other, already reported problem of the screen not turning back on after resuming from Standby or Hibernation.

3. blurgh, at this stage, I have deinstalled anything and everything, but I don't think I checked did the problem still occur, because even if it didn't the machine would be useless to me in that state.  I'm a 3D developer, for IBM and without the proper drivers, for the ATI card, the laptop would pretty much be utterly useless to me.  I can try that, but I'd prefer to try other alternatives first.

4. I'll check now in 2 seconds, I'll need to take it down, manually...

5.  I've installed loads of other software, I've been using the laptop daily, for months now.

6.  my BIOS, according to system info is LENOVO 6FET50WW (1.20 ), 30/10/2008.  any time I've run the BIOS upgrade, from Lenovo, it's told me that everything's up to date and never actually updates.

7.  I just booted into safe mode to check... only to realise that there is no sleep, or hibernate mode in safe mode, so no, it doesn't occur in safe mode.

BSOD Details, here's the screenshot of the BSOD, the windows message thereafter and my graphics driver details.  Hopefully someone can find something from that.

Reply
Answer
Options

25 Posts

11-05-2008

Dublin, Ireland

62 Signins

414 Page Views

  • Posts: 25
  • Registered: ‎11-05-2008
  • Location: Dublin, Ireland
  • Views: 414
  • Message 5 of 5

Re: BAD_POOL_CALLER BSOD on resumer from Standby / Hibernation

2009-02-02, 3:53 AM
I posted my details on the techguy forums and one of the members identified my Comodo Firewall as one of the root causes for the bluescreens.  I've since uninstalled and no I can Sleep and resume to my hearts' desire.  I've posted what happened on the Comodo forums too, so hopefully they'll be able to find a full solution.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms