English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

18 Posts

06-02-2017

CA

87 Signins

459 Page Views

  • Posts: 18
  • Registered: ‎06-02-2017
  • Location: CA
  • Views: 459
  • Message 1 of 4

Choppy 1080p playback - W540

2017-06-22, 20:50 PM

Hi everyone, I bought a w540 and so far it's OK except for playing 1080p videos locally. For some reason, video playback is choppy. The problem happens in any media player (VLC, windows media player, windows metro player). My machine is a quad-core 4700 MQ, 8 GB ram, 2 GB K1100M. For theses specs I think  it's absolutely inaceptable in 2014-2017. Even my 2005 Mac pro with 5GB of ram can handle that... The bizarre thing is that youtube playback is smooth at 1080p to even 4K!

 

The things I tried:

 

-Downgraded from windows 10 to 8.1 with full system format

-Changed power settings to High performace graphics for battery and plugged in

-Change the preferred graphics card to K1100M in Nvidia control planel

-Updated to latest drivers and BIOS from the lenovo support site

-Switched to High performance graphics in BIOS settings

 

When playing video it seems like the nvidia gpu is not kicking in (no activity in nvidia gpu tray icon), it's all handled by the intel gpu. I also tried different videos and they all drop frames at some point in the video. 

 

Can anybody help me out? I am really running out of ideas. I intend to use this laptop for video editing so this is very important to me. 

 

Thank you 

Emil

Solved! See the solution
Reply
Options

3812 Posts

12-02-2007

US

9028 Signins

188478 Page Views

  • Posts: 3812
  • Registered: ‎12-02-2007
  • Location: US
  • Views: 188478
  • Message 2 of 4

Re: Choppy 1080p playback - W540

2017-06-24, 6:39 AM

Hello,

 

I have not used a W540, but I have both a W530 and W510 with FHD (1920×1080) screens and never had a problem playing Blu-ray discs with them.

 

You may want to try ordering the factory recovery media for the W540 from Lenovo and using that to load whichever operating system the W540 originally shipped with, which you can use to get the system into a known-good working condition where full-screen video plays flawlessly.  From there, you can update the software and operating system as needed, until everything's current.

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP72 (20MB-*)P50 (20EN-*)S230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)Yoga 370

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English


Need an answer, fast? Try using Browser Search to find it in the Lenovo and Moto Community
Reply
Options

18 Posts

06-02-2017

CA

87 Signins

459 Page Views

  • Posts: 18
  • Registered: ‎06-02-2017
  • Location: CA
  • Views: 459
  • Message 3 of 4

Re: Choppy 1080p playback - W540

2017-06-24, 18:29 PM
Hi, I tried to get the recovery media but I am not eligible. I have a recovery partition on my hard drive though. Do you know how I can access it to restore my computer ?

Thank you
Reply
Options

18 Posts

06-02-2017

CA

87 Signins

459 Page Views

  • Posts: 18
  • Registered: ‎06-02-2017
  • Location: CA
  • Views: 459
  • Message 4 of 4

Re: Choppy 1080p playback - W540

2017-07-09, 6:17 AM

So I kinda fixed the issue. I uninstalled the nvidia drivers that I downloaded from the nvidia site and let windows install it automatically. I did the same for the intel drivers. Basically I let windows handle everything and video seems smoother all around. I activated DXV or something like that in VLC and it's much faster. Anyway I hope that helps someone.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete