English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

9 Posts

09-05-2008

SoCal

11 Signins

35 Page Views

  • Posts: 9
  • Registered: ‎09-05-2008
  • Location: SoCal
  • Views: 35
  • Message 1 of 27

Did IBM remove the display driver for the W500?

2008-09-05, 4:03 AM

Under the downloads section I can find the driver page for the ATI card but when I try to access the file name its not there.  I checked the FTP site and the directory for the mobility drivers was empty.

 

Anyone know another method to get the drivers?

Reply
Options

9 Posts

09-05-2008

Los Angeles

19 Signins

85 Page Views

  • Posts: 9
  • Registered: ‎09-05-2008
  • Location: Los Angeles
  • Views: 85
  • Message 2 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 4:31 AM
I am in the same boat
Reply
Options

218 Posts

09-05-2008

Cleveland, OH

60 Signins

1049 Page Views

  • Posts: 218
  • Registered: ‎09-05-2008
  • Location: Cleveland, OH
  • Views: 1049
  • Message 3 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 4:37 AM
Same here...  Just got a new W500 that came with XP, trying to load up Vista x64 from the office and lo and behold, no ATI driver.  :(  Had I known I would've saved the drivers folder from the factory install!
Reply
Options

3 Posts

09-05-2008

Chicago

3 Signins

113 Page Views

  • Posts: 3
  • Registered: ‎09-05-2008
  • Location: Chicago
  • Views: 113
  • Message 4 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 4:48 AM
use the thinkvantage preload recovery.
Reply
Options

218 Posts

09-05-2008

Cleveland, OH

60 Signins

1049 Page Views

  • Posts: 218
  • Registered: ‎09-05-2008
  • Location: Cleveland, OH
  • Views: 1049
  • Message 5 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 4:55 AM

My preload was XP Pro.  Don't know if the drivers are different or not but I suspect they are.

 

Also, I wiped the predesktop area (zeroed the first 1% of the drive) to get the space back after making the factory recovery discs.  So, I'm not about to reload XP Pro just to get at the single driver that may not work anyway... especially not right after I finished manually installing all of my other drivers (since Software Update doesn't detect most of the apps/drivers as elegible for install on x64).

Reply
Options

9 Posts

09-05-2008

SoCal

11 Signins

35 Page Views

  • Posts: 9
  • Registered: ‎09-05-2008
  • Location: SoCal
  • Views: 35
  • Message 6 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 17:53 PM

So here's an update to my situation. 

 

I found out the correct intel/ati video driver for both chipsets was C: partition that I blew away.  No recovery media was shipped because they allow you to create your own media by hitting the thinkvantage button and going into the recovery center.  Well that helps since I blew away the C: partition! :)

 

I was in the process of ordering a disk when I realized i didn't blow away the two other partitions on the harddrive.  Turns out these partitions hold the factory image!

 

I installed the lenovo recovery 4.21 software and rebooted.  It gave me an option to reload the factory image.  After 10 minutes the laptop is now back to stock.

 

I now have burned the recovery media so I'm safe.

 

Here's the kicker... there is a SWTOOLS folder and other drivers folder that I've backed up to a USB drive.  I'm reinstalling vista ultimate again and will see how goes.

 

M

Reply
Options

218 Posts

09-05-2008

Cleveland, OH

60 Signins

1049 Page Views

  • Posts: 218
  • Registered: ‎09-05-2008
  • Location: Cleveland, OH
  • Views: 1049
  • Message 7 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 18:36 PM

Any chance you could zip the folder for the ATI driver and throw it on rapidshare or some other file site?  Lenovo's site still doesn't have the file up, and I just called support and the support monkey told me what I already knew (the site seems to be down, try it again in an hour or two :smileymad: ).

 

I'm fairly hosed without that driver so I'd really appreciate the help!

Message Edited by ZPrime on 09-05-2008 02:37 PM
Reply
Options

9 Posts

09-05-2008

SoCal

11 Signins

35 Page Views

  • Posts: 9
  • Registered: ‎09-05-2008
  • Location: SoCal
  • Views: 35
  • Message 8 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 20:35 PM

Sure thing... give me a bit as my upload speed is slow

Reply
Options

9 Posts

09-05-2008

SoCal

11 Signins

35 Page Views

  • Posts: 9
  • Registered: ‎09-05-2008
  • Location: SoCal
  • Views: 35
  • Message 9 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 20:41 PM
http://rapidshare.de/files/40403947/Microsoft.VC80.MFCLOC.zip.html
Reply
Options

218 Posts

09-05-2008

Cleveland, OH

60 Signins

1049 Page Views

  • Posts: 218
  • Registered: ‎09-05-2008
  • Location: Cleveland, OH
  • Views: 1049
  • Message 10 of 27

Re: Did IBM remove the display driver for the W500?

2008-09-05, 21:04 PM
You are a freaking godsend, thank you!  :smileyvery-happy:
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete