Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

13 Posts

12-16-2007

Romania

171 Signins

1119 Page Views

  • Posts: 13
  • Registered: ‎12-16-2007
  • Location: Romania
  • Views: 1119
  • Message 1 of 3

Intel SSD 530 startup problems on ThinkPad W520 - Bug in SSD or lack of BIOS support?

2013-11-13, 14:42 PM

The are problems with Intel SSD 530 and ThinkPad W520. Many people, including me, are complaining about startup problems ... see this thread also: https://communities.intel.com/thread/44258

One month ago I bought an Intel SSD 530 240GB to replace the stock HDD of my ThinkPad W520 (4270CTO). When I cold-start the laptop everything is fine, but when I restart it from Windows 7 or even CTRL-ALT-DEL, the drive is not found. Both SSD and W520 has the latest firmware/BIOS.

I had no problems with Intel SSD 335 240GB; Windows starts and restart without problem, but with the Intel 530 it fails when I do restart, the BIOS does not find it after a normal reset. I think BIOS implementation for W520 does not support the newer ATA feature called "Device Initiated Power Management (DIPM) for Software Setting Preservation (SSP)". There is a BIOS update for W530 but not for W520.

Should I assume Intel SSD 530 is and will remain incompatible with ThinkPad W520 or wait for a BIOS update?

W520 | i7-2720QM | NV Quadro 2000M
Reply
Options

1 Posts

11-27-2013

Seattle, WA

1 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎11-27-2013
  • Location: Seattle, WA
  • Views: 22
  • Message 2 of 3

Re: Intel SSD 530 startup problems on ThinkPad W520 - Bug in SSD or lack of BIOS support?

2013-11-27, 4:57 AM

I am also seeing the exact same issue. I have a ThinkPad W520 and a Corsair Force GS using a Sandforce 2200 series controller. According to the Intel SSD thread, there is some incompatibility between that controller and Intel QM77-chips which is causing the issue.

 

The symptoms for my laptop are the same. SSD is always recognized on cold boot, but effectively never on warm boot / restart. Will we get a BIOS update that fixes this?

 

I have dual boot configuration with both windows 8 and windows 7. The issue is happening regardless of what OS I issue the restart from.

 

Reply
Options

13 Posts

12-16-2007

Romania

171 Signins

1119 Page Views

  • Posts: 13
  • Registered: ‎12-16-2007
  • Location: Romania
  • Views: 1119
  • Message 3 of 3

Re: Intel SSD 530 startup problems on ThinkPad W520 - Bug in SSD or lack of BIOS support?

2013-11-27, 14:42 PM

Just remove Intel RST and the drive will perform as expected.

To do that go to device manager and choose Microsoft driver.

 

I know this is not a final solution but it works.
 Lenovo must issue a new BIOS, otherwise I will not buy from them anymore.

W520 | i7-2720QM | NV Quadro 2000M
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms