English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 1 of 34

Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-09, 12:08 PM

I have had a Linksys BEFW11S4 Version 4 Wireless router for quite some time.  It works like a champ and I have one Laptop wired to it and a second using Wireless working just fine.  Recently, I received a new ThinkPad W500 Laptop with an Intel WIFI Link 5100 AGN wireless network adapter.  The older laptop (ThinkPad T60p) that works just fine with the router uses a

11a/b/g Wireless LAN Mini PCI Express Adapter by Atheros.  However, the NEW laptop (the W500) with the Intel Adapter fails to connect to the Router.  It will either indicate a failure while "Waiting for Association" or it will indicate a failure when waiting to "renew IP Address".  Sometimes, it will show a signal strength close to ZERO (Even as the older laptop with the other adapter is showing a signal strength close to 100%) When I called Linksys support, I was told that the facts that the Router (a) works find with the wired Laptop and (b) works fine with the 11a/b/g NEtwork Adapter and (c) works fine when WIRED to the new laptop all indicate that the problem is NOT with the router at all -- but with the Network Adapter.  Can anyone tell me what has to be adjusted in the Adapter settings?  Right now, I am using IBM Access Connections for BOTH of the wireless laptops.  I have made sure to set IDENTICAL values for SSID and WEP (128-bit) [static] password.  I have also ensured that all OTHER settings are the same for the two laptops.  Yet, in one laptop, there is NO PROBLEM while in the other, I can not get the Wireless Adapter to "see" the signal from the Router.  To further check this, I have [temporarily] disabled the WEP password, enabled SSID broadcast, and disabled the MAC address restrictions that I put in (so that the system would be totally "open" ) yet the Intel Adapter STILL did not "find" anything.  In addition, when I use the "Find WIFI" feature in Access Connections, I find that SOMETIMES the network with SSID is found and sometimes, it will display "unknown network" and not pick up the SSID.

This is all very frustrating.  If anyone has experience with the Intel WIFI Link 5100 AGN Adapter, I would appreciate any hints, tricks, ideas, etc.

Think you!!!!

 

--Zvi

Message Edited by JaneL on 03-09-2009 08:50 AM
Solved! See the solution
Reply
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 2 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-09, 19:38 PM

I would like to add some information that I left out that MAY be crucial here.

On the NEWER ThinkPad, I am using Access Connections 5.02.  At work, the wireless adapter works properly and I am able to use the Intel Adapter.

It is only at home where I have the Linksys Router that I have a problem.

I also noticed that when I looked at the Wireless Driver Properties, there was NO tab for "wireless" -- which I would have expected to see....

Instead there are only TWO tabs... one for "General" and one for "Advanced"... Just like what you would see for an Ethernet

Adapter.....

 

this all looks a bit weird to me.....

As I did not configure this laptop, I do not know if the Hotkey and Power Manager were installed BEFORE the Access Connections or not....

 

any ideas?

 

TIA

 

--Zvi

Reply
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 3 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-10, 13:12 PM

Here is some more information:

I upgraded my Access Connections from 5.02 to 5.20.

As far as I know, that is the LATEST version.

I also verified that I have the LATEST version of the

Driver(s) for the Intel WIFI Link 5100 AGN Adapter.

What I now find is that when I try to access my wireless,

I can authenticate to the Router BUT I I fail to connect

while "waiting for IP Configuration".

The diagnostic is that that the "Server" (i.e.,

the Router) is failing to supply an IP Address to

the Laptop.

Is there ANY other advice short of (a) replacing my

Router or (b) getting a new (additional) Wireless adapter?

Linksys actually suggested that I get their USB Wireless Adapter

(WUSB54GSC, I think) since they seem convinced that the problem

lies in the ADAPTER that comes with the W500.

 

All help appreciated.  TIA.

 

--Zvi 

Reply
Options

5884 Posts

11-24-2007

US

12809 Signins

291260 Page Views

  • Posts: 5884
  • Registered: ‎11-24-2007
  • Location: US
  • Views: 291260
  • Message 4 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-10, 14:44 PM
by any chance, do you have MAC address filtering on your linksys?

ThinkStation P700      ThinkPad X1C7

Reply
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 5 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-10, 15:51 PM
I had MAC Address filtering in place (which worked just FINE with the T60p) but I disabled it for now to minimize any potential problems....
Reply
Options

3 Posts

03-11-2009

Auckland New Zealand

10 Signins

22 Page Views

  • Posts: 3
  • Registered: ‎03-11-2009
  • Location: Auckland New Zealand
  • Views: 22
  • Message 6 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-11, 8:45 AM

I had similar problem with a customer's SL500. sometimes connect, sometimes wont. called IBM, they said they would call back in two hours. They haven't done that yet.

 

Let me know if someone has a fix.

 

Cheers

 

Michael

 

Reply
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 7 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-11, 15:06 PM

Based upon the feedback that I have received from both Technical Support at Linksys as well as the User Forum there, I have decided to upgrade my Router from BEFW11S4 to a WRT54G.  Apparently, this Intel Adapter "has issues" but performs well with that Router.  I iwll let you know what happens...

--Zvi 

Reply
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 8 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-12, 0:51 AM

Well, I upgraded the Router and I have both "Good news" and "Bad news"...

The "Good news" is that the Intel WIFI Link 5100 AGN Adapter was able to

establish a connection with the WRT54G Router.  I implemented WPA security

instead of WEP (I did not do WPA2 because I only have Windows XP SP2

and I was not prepared to upgrade to SP3) and also used AES.  The connection

was established and "held".  It held even when I disabled the SSID broadcast.

 So, in general, this is all for the good.

 

The Bad News is that I prefer to use Wireless MAC Filtering as an additional

security measure.  I went in to set up the MAC list and

CAREFULLY (I think) copied what I *thought* was the MAC Address [from

a tiny label on the bottom of the ThinkPad].  However, as soon as I tried to

connect, the connect failed -- failed on "association".  As soon as I disabled the

MAC filtering, the connection went RIGHT through.

 

So, my questions now:

 

a. Is there any way to truly verify what the MAC address of that adapter is supposed

to be?  E.g., is there some network setting that will let me really know what the

[wireless] MAC address is supposed to be?

 

b. Has anyone else encountered a similar problem -- where the MAC filtering

seems to fail?

 

Thank you!!

--Zvi

Reply
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 9 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-12, 1:22 AM

Well, I can report that the final issue appears to have been resolved!

It turns out that the MAC address on the label is for the GigaBit ETHERNET

Adapter (which, of course, did me NO GOOD at all!!).

However, I found out that if you do Run -> Cmd

(which gives you a "DOS Box") and then enter

the command: ipconfig /all

then you will get the "physical address" for each adapter

(or pseudo-adapter) installed.  When I did that,

I got the CORRECT MAC address to use and then everything

worked.  Of course, it might have made more sense to supply

the Wireless MAC Address, to begin with.....

 

--Zvi

 

Reply
Options

29 Posts

12-24-2008

Edison, NJ

58 Signins

326 Page Views

  • Posts: 29
  • Registered: ‎12-24-2008
  • Location: Edison, NJ
  • Views: 326
  • Message 10 of 34

Re: Intel WIFI Link 5100 AGN Network Adapter does not recognize Linksys Wireless Router

2009-03-13, 20:57 PM

I am now up and working on the W500 with the WRT54G Router.  However, I have the following question.  It was strongly suggested to me that I use WPA2 instead of WPA for the password / security of my Network.  However, Windows XP SP2 does not support WPA2 (though Microsoft has a special patch to add that capability).  However, since I am using IBM Access Connections to manage the connections and NOT using Windows XP for this, I would like to know whether Access Connections supports WPA2 -- in which case, I would be able to implement this....

Does anyone know???

Thank you!!!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete