Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

3 Posts

07-09-2016

Germany

11 Signins

28 Page Views

  • Posts: 3
  • Registered: ‎07-09-2016
  • Location: Germany
  • Views: 28
  • Message 201 of 299

Re: Lenovo P50 - HDMI not working

2016-09-01, 11:00 AM

Please enter page 17 of this blog, You will find all instructions to update thundbolt-software.

Regards Claus

Reply
Options

7 Posts

03-25-2016

United States of America

6 Signins

35 Page Views

  • Posts: 7
  • Registered: ‎03-25-2016
  • Location: United States of America
  • Views: 35
  • Message 202 of 299

Re: Lenovo P50 - HDMI not working

2016-09-03, 16:56 PM

I updated my thunderbolt driver following the instructions, but the hdmi still doesn't have any sound output and I still can't find the TV in "Sound-Playback". Plz Help

Reply
Options

6 Posts

02-23-2016

France

15 Signins

130 Page Views

  • Posts: 6
  • Registered: ‎02-23-2016
  • Location: France
  • Views: 130
  • Message 203 of 299

Re: Lenovo P50 - HDMI not working

2016-09-03, 17:27 PM
Go to the device manager and make sure all the audio related drivers are enabled.

For some reason, at least when I updated the thunderbolt driver, one of the audio drivers was disabled. After enabling it everything worked fine.

David
Reply
Options

7 Posts

03-25-2016

United States of America

6 Signins

35 Page Views

  • Posts: 7
  • Registered: ‎03-25-2016
  • Location: United States of America
  • Views: 35
  • Message 204 of 299

Re: Lenovo P50 - HDMI not working

2016-09-03, 20:55 PM

Hi David,

Thanks for answering my question. I did enable all the sound-related drivers. Under "sound, video and game controllers" I only one driver called realtek high definitino audio. I don't know if im missing something or what. I have already install the firmware update three times, and set my graphic card to discrete.

 

Sheldon

Reply
Options

1 Posts

09-11-2016

United States of America

1 Signins

17 Page Views

  • Posts: 1
  • Registered: ‎09-11-2016
  • Location: United States of America
  • Views: 17
  • Message 205 of 299

Re: Lenovo P50 - HDMI not working

2016-09-11, 13:58 PM

I've followed all the steps, the firmware is updates, I still can't get my HDMI port to work, or at least the monitor hooked to it does nothing. What next?

Reply
Options

2 Posts

09-12-2016

France

2 Signins

36 Page Views

  • Posts: 2
  • Registered: ‎09-12-2016
  • Location: France
  • Views: 36
  • Message 206 of 299

Re: Lenovo P50 - HDMI not working

2016-09-12, 6:48 AM

I have the same problem. I folow all the steps but it doesn't work.

Please help me.

Reply
Options

2 Posts

09-12-2016

France

2 Signins

36 Page Views

  • Posts: 2
  • Registered: ‎09-12-2016
  • Location: France
  • Views: 36
  • Message 207 of 299

Re: Lenovo P50 - HDMI not working

2016-09-12, 7:34 AM

I have the same problem. I folow all the steps but it doesn't work.

Please help me.

Reply
Options

21 Posts

03-20-2016

Germany

24 Signins

302 Page Views

  • Posts: 21
  • Registered: ‎03-20-2016
  • Location: Germany
  • Views: 302
  • Message 208 of 299

Re: Lenovo P50 - HDMI not working

2016-09-12, 11:44 AM

Are there any news about the Thunderbolt Update for Linux?

Reply
Options

1609 Posts

09-16-2014

United States of America

3048 Signins

61403 Page Views

  • Posts: 1609
  • Registered: ‎09-16-2014
  • Location: United States of America
  • Views: 61403
  • Message 209 of 299

Re: Lenovo P50 - HDMI not working

2016-09-12, 13:24 PM

Linefader,

 

Lenovo hoped to publish a Linux version in Q3, but the date with Intel has slipped to Q4.

 

Thank you,

Reply
Options

21 Posts

03-20-2016

Germany

24 Signins

302 Page Views

  • Posts: 21
  • Registered: ‎03-20-2016
  • Location: Germany
  • Views: 302
  • Message 210 of 299

Re: Lenovo P50 - HDMI not working

2016-09-16, 18:45 PM

hopefully the firmware update for Linux will be available soon. I am not using Windows at all (I removed it from my harddisk) and I work with multiple monitors most of the time I use this laptop.

 

So far, I could fix HDMI issues with Allen F's trick (see above) - when there was no HDMI signal, I switched to hybrid mode, then I switched back to discrete mode and then the HDMI signal was there again.

 

However, curretly I cannot open the BIOS menu anymore: the screen with the message "press enter to open BIOS" does not appear anymore at startup time. I tried holding down the F1 and F12 keys but this did not help. I can run a hardware check when I boot with the F10 key pressed, but I simply can't get back into the BIOS menu. Can anybody help?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms