English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

275 Posts

10-26-2010

US

1372 Signins

9382 Page Views

  • Posts: 275
  • Registered: ‎10-26-2010
  • Location: US
  • Views: 9382
  • Message 1 of 19

New W540 BIOS 2.28

2016-09-07, 16:36 PM

Has anyone tried this update yet? I have an issue with my computer crashing when resuming from sleep ever since Windows 10 Anniversary Update. I want to make sure this update is safe so I can see if it fixes the issue.


W540: i7-4700mq, K2100m, 16 GB RAM, 500 GB Samsung 840 EVO
T510: i7-620m, NVS 3100m, 8 GB RAM, 500 GB Samsung 840 EVO
Reply
Options

10969 Posts

01-02-2010

US

39567 Signins

412642 Page Views

  • Posts: 10969
  • Registered: ‎01-02-2010
  • Location: US
  • Views: 412642
  • Message 2 of 19

Re: New W540 BIOS 2.28

2016-09-07, 17:32 PM

I installed it and it seems to be working for me.


Rich


To help with forum searches, check this out: https:/forums.lenovo.com/t5/Welcome-FAQs/Using-Browser-Search-to-find-your-answers-in-Lenovo-and-Moto-Community/m-p/5016916

I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

5 Posts

09-10-2016

TR

2 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎09-10-2016
  • Location: TR
  • Views: 53
  • Message 3 of 19

Re: New W540 BIOS 2.28

2016-09-10, 11:37 AM

I installed 2.28 BIOS version on my W540 yesterday and my system crashed. I have Windows 7 64-bit, and it holds when it tries to load Windows. I cannot rollback to previous versions of BIOS since it is noted in the readme. I resetted my BIOS by removing the BIOS battery, but it did not work. I even tried to reinstall Windows, and it holds in the second screen, so it is not possible to reinstall windows (I even think that it is not Windows related). Any idea how to fix it? 

Reply
Options

8070 Posts

01-13-2008

US

77119 Signins

2180964 Page Views

  • Posts: 8070
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2180964
  • Message 4 of 19

Re: New W540 BIOS 2.28

2016-09-10, 14:48 PM

Hi,

 

Are you running windows 7 in UEFI mode?  If so you need to enable CSM support in BIOS.  Without it both the installer and the installed OS will hang.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English


Using Browser Search to find your answers in Lenovo and Moto Community


Reply
Options

5 Posts

09-10-2016

TR

2 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎09-10-2016
  • Location: TR
  • Views: 53
  • Message 5 of 19

Re: New W540 BIOS 2.28

2016-09-10, 15:01 PM
Hi, when I set the bios to UEFI only, then it cannot find the os or installation cd and asks for the boot order. If I set it to both (uefi and legacy) and boot priority is UEFI first, then same problem, hangs when it loads Windows. CSM is enabled for UEFI. What can I try now?
Thanks in advance.
Reply
Options

8070 Posts

01-13-2008

US

77119 Signins

2180964 Page Views

  • Posts: 8070
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2180964
  • Message 6 of 19

Re: New W540 BIOS 2.28

2016-09-10, 15:05 PM

If it doesn't find the OS in UEFI mode it's probably installed in legacy mode - so the CSM issue wouldn't apply.

 

Sorry I don't have anything else to suggest.  Hopefully others will.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English


Using Browser Search to find your answers in Lenovo and Moto Community


Reply
Options

5 Posts

09-10-2016

TR

2 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎09-10-2016
  • Location: TR
  • Views: 53
  • Message 7 of 19

Re: New W540 BIOS 2.28

2016-09-10, 15:10 PM
Thanks for your help.. Do you think that it is possible to reinstall BIOS 2.28? When I try this, it says it is not needed. I strongly believe that there was a problem in the installation. However, I neither cannot rollback now, nor reinstall 2.28. I am totally stucked.
Reply
Options

8070 Posts

01-13-2008

US

77119 Signins

2180964 Page Views

  • Posts: 8070
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2180964
  • Message 8 of 19

Re: New W540 BIOS 2.28

2016-09-10, 15:14 PM

Here's something else to check.  Disable DEP.

 

https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/T450-Windows-splash-freezes-after-BIOS-update/m-p/3392269/highlight/true#M111256

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English


Using Browser Search to find your answers in Lenovo and Moto Community


Reply
Options

5 Posts

09-10-2016

TR

2 Signins

53 Page Views

  • Posts: 5
  • Registered: ‎09-10-2016
  • Location: TR
  • Views: 53
  • Message 9 of 19

Re: New W540 BIOS 2.28

2016-09-10, 15:24 PM
Hey, I got my system back :) Thank you so much :) Do you think that this is a bug, and will be fixed in the next release? So I can enable DEP again? I do not have so much information about DEP, but just found this:
https://support.microsoft.com/en-us/kb/912923
Reply
Options

8070 Posts

01-13-2008

US

77119 Signins

2180964 Page Views

  • Posts: 8070
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2180964
  • Message 10 of 19

Re: New W540 BIOS 2.28

2016-09-10, 15:30 PM

Reading through that thread I linked, it looks like a bug or conflict of some kind.  It's been reported to engineering.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English


Using Browser Search to find your answers in Lenovo and Moto Community


Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete