Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

25 Posts

10-17-2008

Toronto, Canada

124 Signins

2173 Page Views

  • Posts: 25
  • Registered: ‎10-17-2008
  • Location: Toronto, Canada
  • Views: 2173
  • Message 1 of 8

OTHER W500 GPU PROBLEMS

2008-11-12, 8:02 AM

Hello All,

I downgraded my w500 to xp and am having problems with the graphics card.

1. When I log onto windows a notification bubble pops up says: "Found New Hardware - Video Controller (vga compatible)" followed by the Found New Hardware Wizard window launching.  When I go to Display properties -> Advance button -> Adapter tab, all information shows <unavailable>.  How can I make windows xp detect the GPU?

2. Also, probably related to the above problem, the maximum screen resolution now in xp is 1400 x 1050 vs. the maximum resolution when in vista was 1680x1050.

3. Finally, the ATI Catalyst Control Centre has dissappeared

Sorry for all these questions, have been trying to figure this out for the past 2 hours, very frustrating!

Thanks

 

Reply
Answer
Options

4096 Posts

01-05-2008

Germany

22176 Signins

317410 Page Views

  • Posts: 4096
  • Registered: ‎01-05-2008
  • Location: Germany
  • Views: 317410

Re: OTHER W500 GPU PROBLEMS

2008-11-12, 8:17 AM

 

Hello,

 

check this if you have updated your bios.

 

 

Version 1.18-1.01

  • [Important] An incorrect display adapter name is displayed on ATI FireGL V5700 model (ThinkPad W500).

    Note: Make sure that you have updated the display driver with the following version before BIOS update
    . -ThinkPad Switchable Graphics Driver for Windows Vista Version 8.52.4.4-080919a-069896C-Lenovo (7vd535ww) or later or -ATI Display Driver for Windows XP Version 8.503.2.2-080818a-069536C-Lenovo (7yd119ww) or later Or you will be asked for an appropriate driver for a newly found hardware device and the display may be VGA(640x480) mode. In VGA mode, your icon arragement on the desktop will be messed up.
  • (Fix) The external display may have blank screen when the computer is attached to the Docking Station with the LCD closed and then is powered on.
  • (Fix) Serial ATA Controller mode option setting is set as wrong value via WMI interface.

 


Also, the switchable gfx feature isn´t availiable in XP.

Message Edited by Agotthelf on 23-11-2008 03:12 PM

_________________________________________________________
Follow
@LenovoForums on Twitter!
Try the forum search, before first posting: Forum Search Option
Please insert your type, model (not S/N) number and used OS in your posts.
I´m a volunteer here using Lenovo Yoga C930, ThinkPad X1 Carbon 5th Gen. Silver Edition, ThinkPad 13, Yoga 900, ThinkPad T460s, IdeaCentre B540.
TIP: If your computer runs satisfactorily now, it may not be necessary to update the system.

English English Community      Deutsche Deutsche Community      Español Comunidad en Español

Reply

Replies(7)
Answer
Options

4096 Posts

01-05-2008

Germany

22176 Signins

317410 Page Views

  • Posts: 4096
  • Registered: ‎01-05-2008
  • Location: Germany
  • Views: 317410
  • Message 2 of 8

Re: OTHER W500 GPU PROBLEMS

2008-11-12, 8:17 AM

 

Hello,

 

check this if you have updated your bios.

 

 

Version 1.18-1.01

  • [Important] An incorrect display adapter name is displayed on ATI FireGL V5700 model (ThinkPad W500).

    Note: Make sure that you have updated the display driver with the following version before BIOS update
    . -ThinkPad Switchable Graphics Driver for Windows Vista Version 8.52.4.4-080919a-069896C-Lenovo (7vd535ww) or later or -ATI Display Driver for Windows XP Version 8.503.2.2-080818a-069536C-Lenovo (7yd119ww) or later Or you will be asked for an appropriate driver for a newly found hardware device and the display may be VGA(640x480) mode. In VGA mode, your icon arragement on the desktop will be messed up.
  • (Fix) The external display may have blank screen when the computer is attached to the Docking Station with the LCD closed and then is powered on.
  • (Fix) Serial ATA Controller mode option setting is set as wrong value via WMI interface.

 


Also, the switchable gfx feature isn´t availiable in XP.

Message Edited by Agotthelf on 23-11-2008 03:12 PM

_________________________________________________________
Follow
@LenovoForums on Twitter!
Try the forum search, before first posting: Forum Search Option
Please insert your type, model (not S/N) number and used OS in your posts.
I´m a volunteer here using Lenovo Yoga C930, ThinkPad X1 Carbon 5th Gen. Silver Edition, ThinkPad 13, Yoga 900, ThinkPad T460s, IdeaCentre B540.
TIP: If your computer runs satisfactorily now, it may not be necessary to update the system.

English English Community      Deutsche Deutsche Community      Español Comunidad en Español

0 person found this solution to be helpful.

This helped me too

Reply
Options

25 Posts

10-17-2008

Toronto, Canada

124 Signins

2173 Page Views

  • Posts: 25
  • Registered: ‎10-17-2008
  • Location: Toronto, Canada
  • Views: 2173
  • Message 3 of 8

Re: OTHER W500 GPU PROBLEMS

2008-11-12, 14:32 PM

Thank you Agotthelf!

 

I re-read the passage you quoted, as I saw that post from mark_lenovo but I guess didn't really READ it, and went back to the lenovo website and carefully read the installation instructions which said to extract the (7yd119ww) file.  The extraction part is super important which I overlooked the first time.

 

Anyways, GPU is recognized by xp now.  Next step to update the bios for the ATI FireGL thing... hopefully we get some sort of resolution on that.

Reply
Options

4096 Posts

01-05-2008

Germany

22176 Signins

317410 Page Views

  • Posts: 4096
  • Registered: ‎01-05-2008
  • Location: Germany
  • Views: 317410
  • Message 4 of 8

Re: OTHER W500 GPU PROBLEMS

2008-11-12, 16:27 PM
We´re working on that.:smileyhappy:

_________________________________________________________
Follow
@LenovoForums on Twitter!
Try the forum search, before first posting: Forum Search Option
Please insert your type, model (not S/N) number and used OS in your posts.
I´m a volunteer here using Lenovo Yoga C930, ThinkPad X1 Carbon 5th Gen. Silver Edition, ThinkPad 13, Yoga 900, ThinkPad T460s, IdeaCentre B540.
TIP: If your computer runs satisfactorily now, it may not be necessary to update the system.

English English Community      Deutsche Deutsche Community      Español Comunidad en Español

Reply
Options

3 Posts

11-14-2008

WA

3 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎11-14-2008
  • Location: WA
  • Views: 40
  • Message 5 of 8

Re: OTHER W500 GPU PROBLEMS

2008-11-14, 7:08 AM

Agotthelf,

 

 

I have bios 1.22 and vista ultimate x64, my fireGL V5700 is mistaken as HD 3650 with a yellow ! sign in devmgmt.msc. Do I need to downgradet my bios to 1.18, install the driver then upgrade BIOS back to 1.22?

 

 

Reply
Options

3 Posts

11-14-2008

WA

3 Signins

40 Page Views

  • Posts: 3
  • Registered: ‎11-14-2008
  • Location: WA
  • Views: 40
  • Message 6 of 8

Re: OTHER W500 GPU PROBLEMS

2008-11-15, 7:17 AM

Solved!

 

It needs BIOS 1.18 or later. After upgrade BIOS to 1.19, http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-70354

 

I reinstalled the package downloaded from: http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-70417

 

After reboot, w500 finally recognized the FireGL v5700 Video Card.

 

 

I was tricked by SMBIOS version which is 2.4.  And the system update didn't pick up any BIOS update. Based on those two facts, I thought I had latest BIOS. I am minutes away to call sale and have this laptop returned as the support technician think my W500 might have a wrong video card!

 

 

Reply
Options

22 Posts

11-11-2008

Morocco

57 Signins

389 Page Views

  • Posts: 22
  • Registered: ‎11-11-2008
  • Location: Morocco
  • Views: 389
  • Message 7 of 8

Re: OTHER W500 GPU PROBLEMS

2008-12-01, 9:39 AM

Actually it's not a problem of being recognized as firegl 5700, personnaly I don't care of the appearance, I just want the opengl capability!

 

Even when the card is recognized as firegll 5700 we don't have the hardware acceleration!!!

Reply
Options

2 Posts

11-30-2008

USA

6 Signins

100 Page Views

  • Posts: 2
  • Registered: ‎11-30-2008
  • Location: USA
  • Views: 100
  • Message 8 of 8

Re: OTHER W500 GPU PROBLEMS

2008-12-01, 19:34 PM

I updated to BIOS 1.19 BEFORE I updated the Switchable Graphics Driver Version 8.52.4.4 for Vista. Now I can't use the ATI card. Does anyone have any suggestions to fix this problem?

 

 

EDIT:  Never mind, I went into the BIOS and switched  to discrete graphics, disabled detect switchable graphics and now it works. I even got my full 3 gigs of memory now instead of 2.5. 

Message Edited by lenw500ovo on 12-03-2008 11:39 AM
_________________________________
4058CTO T9400 Vista H Premium 32-bit
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All